Strava sync running pace error

Hi, i’m using strava to walk while working and when sync the activities into strava the pace and duration shown is wrong.

Screenshot 2023-11-22 at 12.02.34

Not sure if this is zwift or how strava is handling the information.

You’ll need to give more information.

What are you using for speed on your treadmill?

Are you recording to Strava separately or allowing Zwift to upload?

i’m using a treadmill connected to the Bluetooth on my mac. After that, i sync the activity with strava.

During the activity the time and speed work perfectly on zwift. As you can see in the picture below
Screenshot 2023-11-22 at 12.55.12

Once synchronised with strava, the info is not correct

I am having the same error - not all the time though. It has only happened to me twice and both times, I could not even re-upload the .fit file to make it work.

The funny thing is that in Intervals (which syncs from Strava), the pace is there and correct. It is also there and correct in Zwift…

I am using the Runn Sensor with a Wahoo Tickr HRM. I dual record on my Garmin watch in “Treadmill” mode, just in case. In this mode, it does not pair with the Runn.

I’m having exactly the same.iaaue the data in Zwift is correct but the API / data transfer to Strava shows the wrong moving time meaning the pace is wrong.

I’m.usimg a Bluetooth treadmill (not pod) to capture the data in Zwift.

yeah, i have an issue open in strava support and this seems to be the root cause. Not sure how the calculate the moving time but it is wrong, and give the wrong pace… they should use the elapsed time instead when transmitted to strava through api

Thanks Pedro, have you got a link so I can upvote the problem?

not sure if you would have access as it is a support desk item.