Strange camera behaviour in France

I have noticed this the last few times I have ridden in France where the default camera angle (number 1) seems to bounce in and out a lot more than it does elsewhere.

it seems to happen when something is happening in the scenery, going under a bridge, through the sections with buildings/people etc

it zooms right in to past the rear wheel then bounces back out and then back in again.

Something like this perhaps?

What I also suspect is that you encounter something called rubberbanding effect. That’s when the game engine hops through the 60fps mark back and forth and therefore creating this effect of constant zooming in/out.

You mentioned in the other thread that you captured a video? If it’s not too big, you can drag and drop that into your response. If it’s a giant video file, you may have to upload it to Youtube/Vimeo and drop the URL for that video here.

Noticed you’re on Windows 10. Do you know how to capture video? This site walks you through the steps with Win10’s built-in capabilities. No need to install any software to do it.

If you both would show us what you’re seeing, it’d be much appreciated.

Yeah i’ll give it a go.

happens everytime - it is quite odd, it seems like the camera is moving at a constant speed but the avatar bounces forwards and backwards where the camera will catch right up so that half of the back wheel is off screen then the avatar will speed off and then come back again.

Only happens in France for me.

1 Like

If it’s the effect I’m thinking of, it happens to me in every world, usually when going down a hill at high speed. The “rubber-banding” @Mike_Medwed describes sounds exactly what I’ve experienced. I just kinda shrugged it off as a quirk of the game.

NOTE: same thing on iPad, AppleTV, and PC maybe PC, can’t confirm.

If I think of it next time I’m riding I’ll try to take a screen cap or make a short vid.

IMO, this isn’t going to get fixed anytime soon - it’s likely just a quirk of the proprietary game engine and will need a complete code refactor.

If it’s the old 60fps thing, it can be minimised by capping the frame rate to 61fps when using a typical TV or fixed refresh rate 60Hz monitor. Been going on as long as I can remember. If you use a higher refresh rate display and can stay away from 60fps it doesn’t happen.

Here’s what it looks like, though this is an old video with settings manipulated to force the frame rate to hover around 60fps. 20200810_194523.mp4 - Google Drive

This obviously doesn’t apply if the behaviour is also being seen on lower end devices, but it could still be related to vsync (probably 50% refresh rate, so 30fps). Be worth trying a 31fps cap.