Steering on mountain bike course - feedback!

Zwift team thanks for the epic upgrade with steering on the mountain bike course!! Zwift just keeps getting better and better!

Shane Miller’s video about the course was great! Top effort Zwift team!
Youtube - Shane Miller video

Spent a frustrating hour trying the new course. Maybe my phone isn’t sensitive enough (Samsung A30) but I just couldn’t get any reliability out of the steering. I’d start the course and it would be working somewhat OK but after halfway through I couldn’t turn at all and had to reset the steering after running into a rock wall.

Adjusting the sensitivity slider on my iPad was a near impossible task with repeated attempts failing to register finger taps or drags.

Quiting the course returns you to the road but just beyond the turn-off so you have to turn around, go back a bit and turn around again to pick-up the turn-off for the MTB course. It might be nicer if the avatar was placed further back down the road so you didn’t have to do a couple of u-turns to re-do the course.

I doubt I will be trying it again unless Zwift adds some sort of auto-steer option. I’m just not interested in dealing with frustrating and unreliable user interface issues. With steering I think it’s going to be great if your particular setup works well but if it doesn’t (inconsistent and unreliable steering inputs) then it’s no fun at all.

2 Likes

Steering is excellent. After a couple of minor tweaks I found it very natural and felt it mirrored my movements exactly. Loved that I could also steer by leaning the bike thanks to Kinetic Rock & Roll trainer.

Only problem was sometimes could not see course ahead. I like to ride first person (keypad 3) and occasionally lost sight of the trail ahead. It needs to look down to the trail ahead in those instances.

Excellent feature.

2 Likes

Overall, I’m excited about steering. That said, my results were mixed. I used an iPhone 6 through Apple TV. The accuracy of the steering seemed to fluctuate. It seemed to degrade as I went on. Eventually, my handlebars would need to be turned to the left in order to go straight. I’d recalibrate, straight would be straight for a bit, then fade again. Very promising though!

Nice feature if you can get it to work. I couldn’t, possibly an issue with my phone.

Could do with the ability to test if the steering is working and see the rider moving the bars in sync with your movements before starting the course.

2 Likes

I can’t get on the MTB course, I’ve updated to the latest apps, although in the apple apps store it says updated 4 weeks ago with no new update. I am running Zwift through an iPhone 6s and the companion app through an iPhone 5. If I cycle to the course nothing happens, I can see other riders going on the course but I don’t get the option. Both apps are using the same WiFi network and both are synced. Any idea why it’s not working? And do I have the latest update (is there something wrong in my apple store??)

Thanks Ben

Had a go today using an iPad Air paired with my Samsung note 10 and my direto. I was looking forward to it and it’s been ruined by the following facts.
Steering is fine then goes beserk so it’s impossible to get any consistency. Nigh on impossible to set sensitivity on iPad as wont register a touch then also goes beserk. Sad to say I won’t be using this again and will stick to the normal zwift img from now on. Far too much faffing about for nothing to show.

Got it working, update for app appeared in store :slight_smile: fun and totally different Zwift experience, it worked best with sensitivity set to lowest setting for me.

After 4 runs on the new ATB course these are my thoughts:

  • The steering works well (without any adjustments to sensitivity). I think the learning curve is very good, it takes some time to get used to, but not too much! In my opinion it shouldn’t be too easy (just like mountainbiking is not easy), but shouldn’t be too difficult either. Current implementation is well balanced.
  • Just like irl you need to get to know the course to steer through it well, so I like that the current arrow signs and sharp bends are subtle and realistic enough and make it not too easy
  • I found a bug/glitch where after I obtained the MTB, my avatar stopped moving, though I did pedal on.
  • We need to do another lap of the course without doing a manual U-turn
  • I like the idea with different bikes/wheels having different speeds depending on surface, but the current implementation was done too sudden. I see a lot of complaints of the effect on group rides esp. on the Jungle course.
  • My neighbour tried it but the course didn’t appear. Probably because he used the Zwift app on an Android smartphone while also running zwift companion app. Would be strange if he needs an extra smartphone just to make it work…
  • Overall I like the steering very much. And after just a short try, it is very difficult to stop steering when I’m on the regular course :wink:
1 Like

Agree with the testing idea. I tried it tonight and had exactly the same problem, no matter how much I moved the phone it had no effect even with sensitivity cranked up.

if you have a magnetic case the remove it.

I had the same. Can get to the course but no steering. Ben above mentioned he only just got the updated version in the apple app store 2 days ago. I’m using Android companion app and the latest version is still 7th Sep in the Play Store…I wonder if that is the issue but not sure. Checked phone as well and this does have the required technology to support the steering…

(also do not have magnetic case)

edit - just realised i do have a magnetic strip on the back of the phone…will try without

edit 2 - still not working for me :frowning:

I would like to add my voice to those who are enjoying the steering on the mountain bike course and following up what Michiel stated above, I would love it if you could make steering available (as an option, of course) on the Titans Grove course. After finishing the mountain bike section I want to keep steering.
Harry

1 Like

Same issue as others above. Android phone running the Sept 7 version of the app as that is all that is available in the google play store. No steering at all…no case…no magnetic strip…couldn’t find any support faq for setup…have tried several times to no avail…

Seems its not just the rotation of the phone that effects steering, but also the left right tilt? I ride on a rocker platform making the steering very difficult. Its constantly going L/R as my phone tilts with my bike on the rocker. Perhaps tilt shouldn’t be included or a box to turn it off?
Hopefully that makes sense. For the rest of the population not using a rocker I"m not sure why they would need the tilt

So I’ve tried 5 times now and best I can get is 4 stars.

It’s far too inaccurate and even with sensitivity turned down I cannot stay on line. It’s worth on the tight bends.
Time wise it’s tough and you can’t afford to dawdle about to try and ensure you stay on the right line.
For me 10 stars or 9 as it seems to be is too many to get the MTB. You are punished for not being directly on the line. If you miss the first star you may as well about and press quit. At least then it drops you back at the start.

I’ve tried having my phone mounted on the handlebars and then holding it in my hand. Neither work accurately.

Having tried and failed to steer I’m pretty convinced it’s something I don’t actually want from Zwift.

Same issue as others above. Motorola phone running the Android 9, No steering at all… so frustrated

Similar experience, mostly terrible steering.
First run, I had to steer like 90 degree turns left and right. Horrible and did not see anything about recalculating or changing sensitivity.
Second run I picked up the phone and kept it straight but tilted it slightly and found that was working okay (hard to hold it still enough) I got 9 of 10 stars.
The problem is once you miss a gate or star, there’s no point in continuing. It’s just over and I have to finish to restart. I wasn’t interested in a third attempt. Probably some time when I’m tired.

Running Zwift on ipad pro. Tried the companion app on ipod. No steering. Tried again with Android phone. No steering.

Are you on Repack Ridge when you are testing the steering?