Shader cache causing stutter?

Have you tried without adaptive sync and vsync on?

Have you gone into bios and played with some of the settings like disabling cstates, there are a couple of other settings that can impact games by down clicking them CPU rather than run at certain speeds, is your ram also at xmp1?

Nvidia control panel make sure any power or quality settings under Manage 3D settings are set to high performance

Just for s$&ts and giggles turn off all exploit protection in windows

Try all this one at a time and see if it. I don’t have issues with Zwift but suffer similar issues in other games which have been an ongoing nightmare since I put my high end rig together a year ago!!!

One more thing, is your GPU core down clocking? For nvidia GPUs you can lock the core in MSI Afterburner to stop it from down clocking, has always been something that causes stutters in games. I lock my 370 at 1920mhz which via running a few benchmarks seems to be the best value for me

Yes.

Never needed before, but yes.

Yes.

Doesn’t do anything, tested thoroughly in the past.

I don’t see why this would do anything, never needed in the past.

No. Also, never a problem before.

All solid suggestions, but the reason this thread exists is because it’s behaviour that shouldn’t be happening.

1 Like

Whilst I get that my experience has been somewhat different, games are all different and all version updates always seem to introduce new issues. For example in a recent game I play a new version introduced stutters, If I’m in the minority for whatever reason no Dev will look at my particular issue, therefore like you I’m forced to troubleshoot myself.

Disabling exploit protection fixed it. In a later version turning off Shader Cache, deleting all cached files then reenabling fixed stutters.

In other games I’ve had to disable hyper threading, turn off resizable bar in bios LOL. Adjust for tighter ram timings.

It’s a joke. I run a i7 11700K, 32GB 3600 ram, 3070GPU, all games on SSD and 240hz monitor, vanilla Win10, my rig should smash all games at ultra settings, all kit has been tested, all I can think is it has something to be with compatibility of components???

Still the same.

Cracker here from tonight:

Inexplicable.

Noticed tonight that during Zwift, Task Manager shows some system RAM being used for graphics (Shared GPU Memory) even though there is a ton of much faster physical VRAM spare. This clears when the game is closed. :thinking:

image

I assume that your Mainboard has integrated graphics which allocates main ram memory for it’s VRAM.
Both, the integrated graphics and your graphics card can be active in windows and is being switched depending on the power saving settings.

I would recommend to disable the integrated graphics in bios.

Nope. Same behaviour is seen on both a CPU without integrated graphics at all (F SKU) and a CPU with integrated graphics disabled in BIOS.

1 Like

@Dave_ZPCMR did you ever find a fix for this behavior? I have a decent rig and am getting the same thing. My rider looks smooth, everything around the avatar is jumping past in split second intervals. GPU load is around 50% but temps are weirdly high given the load, pushing 80 at times. It will resolve briefly but doesnt seem to be a result of load or anything. I don’t see this behavior in games that are way more intensive. My guess is its whatever proprietary engine Zwift has cobbled together.

That sounds more like this: Riders Stuttering Back and Forth in Pacer Rides; Large Groups [November 2022] - #39 by Gustav_Lindqvist

The issue this thread is about is unresolved (and not acknowledged).

1 Like

Hard to say, my rider movement and those around me stay far smoother than those videos. During WTRL last Tuesday the pack was (or looked) smooth but scenery was jumping past. Took a slo-mo video and you can see everything pause as the scenery goes by. RTX 2070, i5-9600. CPU load never above 30%.

CPU load percentages don’t mean anything in Zwift, it doesn’t extract anywhere near the resources available. You can still be CPU bound when it’s nowhere near 100%. You’re probably just below 60fps, upload a Zwiftalizer link.

The stuttering I’ve been moaning about in this thread is random, and happens no matter how busy it is. I suspect some assets load much more slowly than others, and it causes a blip.

Re: CPU, I know, just providing context relative to the modest GPU draw I mentioned earlier (and in case anyone suggested the rig wasn’t capable). FPS is locked because I have v-sync enabled (60hz monitor). I capture frame rate through Nvidia and its solid - capped vs uncapped makes no difference in what I’m seeing. Drivers are up-to-date, using “conservative” settings in the Nvidia control panel, etc etc etc. Who knows.

Out of curiosity, have you altered the shader cache size?

I don’t muck around with any of the default Nvidia settings other than to enable threaded optimisation and triple buffering - the former of which won’t change anything for you anyway because it’s a quad core. Latter just prevents the frame rate from hard dropping and/or being pegged at 50% refresh rate with vsync. I’ve tested virtually every other setting in the past and they either don’t improve anything or make the visuals worse. Image sharpening is the only one worth bothering with and the effect is barely noticeable anyway. Post a Zwiftalizer log from that WTRL ride if you still have it.

PS: you really need to look at your graphics card’s cooler and/or the airflow on your PC. It shouldn’t be getting that hot under so little load. GPU load percentages are relevant (unlike CPU as discussed), so this isn’t down to Zwift.

That’s the weird part, I can be running upwards of 60-70% GPU utilization in another program and register the same temps. My case has good airflow and I clean it semi-regularly. The fans are set to run aggresively as well. Idle temps are fine. I only see that behavior when running Zwift.

Is it a Founders Edition card? Circa 80deg may be the stock thermal limit, in which case it wouldn’t get any hotter because it’s throttling.

Edit: 89deg is the unlocked limit for a 2070. I would imagine you’re hitting the stock limit. Worth a look with something like GPU-Z or Afterburner. Or test it with Furmark.

Hi Dave.

I have glanced through your posts. You have said you tested multiple systems and they all have stutters related to shader compilation?

Can you please name any other games that stutter?

I have the exact same issue for years now actually. I hope you don’t have this issue, but if you’ve tested multiple systems it sounds like you do.

Any computer I plug into my outlet even through a UPS and Power conditioner causes it to stutter for some reason (horribly) in shader compilation games. I have tested 5 PC’s and the last one has confirmed it as I took it to a friends house before plugging it into mine and it worked flawlessy until it plugged into mine, and it even stayed when I took it back there! Some people have it for only shader compilation games, others have it for any game.

No idea what’s going on. No it’s not Internet related as it happens offline also. Even with a battery UPS and Power conditioner as soon as it hits any outlet in my house it messes something up. Sounds ridiculous, I know. Others have this issue and we have no clue what’s going on.

Hi there. First off I don’t actually know if it’s anything to do with shader compilation, that was just me speculating. It’s probably horseshit. It could be a network thing, or something else totally unrelated.

All that I know is that for many years now my own rig for Zwift has been set up to be as smooth as possible. Initially this was with adaptive sync only, then with progressively more powerful graphics cards to prevent being GPU bound in 4K, and now with a CPU that ensures high frame rates even when it’s very busy with other riders I’ve had multiple adaptive sync monitors in that time too. And yet for the last year or so, the game is noticeably (to me) less smooth when there is no reason for this to occur. There’s a random, brief stutter that looks like a frame time spike. The issue is much more noticeable on a fixed refresh rate display, like a TV or regular monitor. Irrespective of the frame rate, it just doesn’t feel as smooth as it should do, and did before.

I suggested it could be related to the shader cache because it feels as though some graphics - particularly rider avatars and bikes coming towards you - load up more slowly than others. But it can also happen when there’s nobody else around, or when you’re in a group ride and everyone is on screen in the same kit and going in the same direction. So I don’t know. I don’t have any issues with mains power to my knowledge and it’s the same on multiple outlets in my home. Additionally, nothing has changed on my mains power setup for at least a decade of living in the same house, whereas Zwift smoothness has.

I’m very certain at this point that it won’t be investigated or resolved.

This was a stutterfest, for no reason whatsoever: Zwiftalizer 2.0