PC app crash when proceeding post pairing devices page

Since the most recent update, I am unable to progress beyond the pairing page on the PC app. When clicking “OK” zwift becomes unresponsive and I get the windows blue spinning wheel.

Note, I have no issues when using ant+ on android mobile. My setup was also working last week pre the update.

Steps tried:

  • reinstalling pc app from scratch
  • confirming to firmware change for turbo trainer
  • going “just ride”, then pairing through the menu
  • multiple turn it off and on again (pc & turbo trainer)

Lappy specs:

  • Intel Core i7-8750H CPU
  • 16GB RAM

I literally have the same issue! Have you tried setting the resolution to 720p? If you don’t already know, since you can’t get to the settings screen in-game, you can do it manually in your prefs.xml file.

My issue:

Hey Matt, will try later thx and revert.

Why do you think GPU driver related? Are you able to get past the page if you dont pair any devices?


Hi Adam,

I am not able to get past the page even if I don’t pair any devices, so I don’t think it has anything to do with Bluetooth or connectivity.

However, if my settings are at 720p resolution, I can proceed past the page. AND I can then increase the resolution and ride, as I did this morning for 27 miles! But upon restarting Zwift, since it’s in 1080p resolution, the issue again happens. So I go into the prefs.xml file and manually change the resolution back to 1280x720, and Zwift will run again.

For this reason, I believe it’s related to graphics drivers, OpenGL, or something GPU related in Zwift’s code. It only started after the last Zwift update.


What resolution is your monitor? Do you happen to have a widescreen monitor?

Mine is an LG widescreen which runs at 2560 x 1080. Just curious if this is somehow related.

ah that is where we differ, as I am able to proceed if i dont pair

last night i was able to proceed but iff bluetooth was disabled (only allowing ANT+ connections)

FWIW 1080p screen

Gd luck,