Meetup Speeds Incorrect with Small Groups (46km/h or 28mph)

We thought this was just the band keeping us together but we had it disabled tonight after doing 25 miles in less than an hour. Same issue :frowning:

Yep, same here. Pretty annoying. When will it be fixed?!


Same thing happened to me, two person meet-up, really annoying because it ruined a 100 mile first attempt. Even stopped a few times to see if that would reset the speeds back to normal, but we eventually gave up. I didn’t feel comfortable continuing at false speeds, pushing sub 1w/kg and still stuck on 46kph.

I wasn’t able to quit the event either to keep going, had to end my ride completely.

I hope this can be fixed.


I came across this bug looking at the leaderboards for a Strava segment. The tops of the leaderboards are all riders with average speeds of ~28mph from this bug. Example here

I’ve had this happen to me on a two person meetup this morning and a couple of weeks ago. When it happened a couple of weeks ago Zwift let us continue and finish the meetup, however this morning, we got the cone of shame. It split us up and we could not see each other (even though we had keep together on). We both quit out and schedule another meetup for 10 minutes time, however when we joined that one (selected world was even different), I was throttled on speed to snails pace and my partner was riding in mid air. We had to can the meet up and we just elected to ride with pace partners. This will become frustrating if it turns out to be a regular occurrence.

I’m pleased to read that I’m not the only swifter this has happened to. I do a lot of small meet ups but this issue only happens with one specific rider and happens every time. Last night she was showing as ahead of me but on her screen she was behind and also it was telling me that Zwift was looking for riders when both of us had already joined. I tried stopping pedalling and then starting again, as did she. - but soon the speed climbed to 29mph - at one point I was soft pedalling and catching up with emails and still doing 29! it would be great if this could be fixed. Why should it happen with only one rider?

1 Like

Issue is still happening as of March 2021. I’m leading a small group of 3-6 and we’ve been clocking 46 kph/ 29 mph if we’re all pedalling between 2-4 W/kg. Speed is capped on sprints, descents but then we go rampaging up the climbs. It’s very disheartening this bug hasn’t been fixed yet.

I seem to notice a bug on my last ride. My wife and I did a meetup with the option to keep the group together. Both My wife and I were put out 2 wkg or less however we were passing people that were put out a lot more wkg than us, some time 3 or 4 wkg. We were going up hills sometime that were 3% at over 40 kph with only output 2 wkg or less. There were times during the ride where it was closer to reality on speed but a lot of the time we were just passing about everyone. The ride was the “Beach Island Loop Meetup” that I did today.

The application usually works great and we really enjoy it. It was fun passing everyone for a change though. :slightly_smiling_face:



Thats a known issue It appears be common as I see riders experiencing it all the time
I am not sure exactly the status of addressing it , someone else might be able to input that .


+1. I had the same issue today and I was going to report it here but I found similar threads talking about it. Seems this hasn’t been solved yet. The group speed was decreased considerably.

1 Like

The very slow speed (about 16Km/h) happened twice last month. When it happens, the “blob”, or whatever it is called, dynamics are changing and we all ride in a ball shaped bunch or side by side which is in contrast to the usual shape where we are one behind the other. Both times, coincided with a specific person joining but they have not done anything unusual.

Maybe it’s time to do something about this bug? It has been there for years now…
I sometimes saw people claim that the bug appears only if you have an old version of the Zwift app. But it’s obviously happening also in newer versions, since you find that bug clearly at the top of the “Temple KOM from Fishing Village Side” segment of Makuri Island :wink:
Those two women cycled up the hill 3 times at 45.6 km/h with 2.2-2.4 W/kg output - actually, they kept going at that speed for three full loops of Countryside Tour.


I am sure this has been fixed, we haven’t had this happen in months and we used to get it every ride.

I’ll be very surprised if this has been fixed, Gerrie. I’ve seen it happen a couple of months back, but haven’t been in any very small meetups over the last few weeks to test it out.

And Zwift haven’t mentioned it being fixed.

1 Like

It happens for people riding Countryside Tour in Yumezi/Makuri Island (check the link I posted, look up the activities of the two women at the top of the leaderboard), so their app cannot be very old :wink: With an outdated app they wouldn’t be able to access that route.

1 Like

Thanks I will do a meetup on thet route tomorrow.

Hello, I’ve encountered this bug before but this time it was really insane.
I’m a very casual rider and I use the meetup with the keep everyone together feature enabled with one or two friends. I ride about 3 to 4 hours a week on zwift.
Every once in a while one of our friends is late to the meetup time. Most of the time someone joins the keep everyone together meetup after it has started, some kind of issue pops up.
It can be that we get slower speeds like 3 people doing 2-2.5w/kg and we roll at 20km/h on a flat or something, the last time my friend joined the meetup late and I was waiting for him standing still, shortly after he joined I started riding, after some seconds our speed suddenly dropped to 0 then it went to 46km/h and stood there no matter the terrain it was, we were doing road to sky route on the meetup, when we got to the alpe, same thing 46km/h straight uphill.
We were more laughing than training at this point, it was funny riding like 1.5-2w/kg and going 46km/h up the alpe like a motorcycle. To be honest it felt like a single blessing after so many 15-20km/h meetups that our speed was a lot slower than it should have been.
When speeds were slower we just didn’t care about the bug too much but the one we faced yesterday was really game breaking.
We canceled this meetup and made another one and replicated the same settings as before, this time we were locked at 15km/h on the flat, I have video footage of both but I will just post the steps we used to get the bug that locks at a seemingly random speed:

Create meetup with keep everyone together enabled.
Leader of the meetup joins in time, before meetup starts.
When meetup starts, don’t move until the second player that is late to the meetup joins and starts riding.
After a few seconds, speed will be locked at a random value.

I really hope this gets fixed soon, just want to casually ride in the speed we are supposed to ride (:

1 Like


On what system did you run Zwift?

ooo it look like the bug is back?

I was running windows and my friend was running on macos.

1 Like

I can say with certainly that this still exists. I was doing a solo ride in Paris last night. There were several groups of two there that all started at different times, had completed different distances and were all still riding at 45-46 kph with a very wide variation in Wkg output. I was riding 3-3.5ish and was still being passed by them since the speed does not appear to be affected by hills.

I ended up leaving early, but I saw that there were pairs of two that were riding together and had the same distance completed. Very weird.

1 Like