Map, route, and rode with info not showing in activity

I have about 2 weeks of zwift use in and I noticed one day after a ride that my activity in the companion app showed a map, the route I took, other riders I rode with.

That was my 3rd or 4th ride and it had not done that previously or has it done it since. Instead viewing an activity on the companion app just shows the three charts (timeline, power, heart rate).

I have tried many different things to get the map to show up on rides.
Never deviate from the route
End near where I started
Never let my power drop to zero
Save the ride from the pc instead of hitting stop on the app

Does anyone know the secret sauce needed to get this information to show??

On the Zwift Companion App click on your profile pic (top left hand corner)
Scroll down to the bottom and click on Activities
Click on the image for any activity and it should show you the route you took.

The issue I am seeing is once you follow your instructions and viewing a single activity from your activity feed, it does not show me the route I took. Only one of 15 activities does. I am not sure why, or what I did differently for that one activity.

To clarify, once viewing an activity, I am assuming most people see the route, can swipe left to view other stats like the timeline, power distribution, and HR distribution. My activities (all but 1) just have the stats panes. Not route.

What most of my activities look like…

What one activity looks like…

Weird, because I look at your activities in the ZCA it show the map for all of them except for the corrupt one.

I am using an iPhone 7 for the ZCA, so it could be an Android issue.

Check to see if there are any updates for the ZCA.

Interesting.
Thanks for checking! That helps narrow things down.

I reinstalled the companion app, but the results are still the same.

At least I know it isn’t how I am ending rides or something along those lines. Not sure what to try now though…