KICKR and additional power meter


(Christian Eisendle) #1

Hi!

Saw some discussions in this forum about KICKR not changing the resistance (no matter the slope, resistance is always the same).
Today I figured out that once I start using KICKR as power meter source, also the SIM mode seems to work. So far, i’ve been using Power2Max power meter as power source (reason: KICKR is known to report wrong power figures + has temp. drift). When using P2M as power meter source, zwift seems not to control my KICKR, but once I switch from P2M to KICKR as power meter source, zwift is properly controling my KICKR.
Is this known/intentional behavior? Power meter is not the same as smart trainer (former measures output power, the latter sets it). So is there a way to use an external power meter (SRM, P2M etc.) while using the KICKR?

Thanks a lot
Christian.


(Greg Gibson-Haymarket) #2

Right now the only way to have Zwift control the resistance on the Kickr is to set Kickr as power source. The developers have said the ability to control the Kickr from a third party meter will be added at some point, but not yet.


(Christian Eisendle) #3

Thanks a lot for your quick reply. However, there is still one point I don’t fully understand yet: Why is power data required to control the Kickr? IMHO, the SIM mode is implemented within the firmware of the Kickr. So my assumption is: Application sends a command like “Sim mode, gradient 1.5%” and the Kickr controls the resistance depending on the speed. (At least this is how it is implemented within Wahoo app or other programs like PerfPro Studio). In other words: Kickr just implements the ANT+ Power profile for monitoring reason, not for controling reason.
It was just a bit confusing to me that I had to set the Kickr as Power meter source (=sensor) in order to enable it as a trainer. If there would be a dedicated window to select the trainer, it would avoid such (user) mistakes :slight_smile: Don’t get me wrong: I’m not here to blame, I know it’s beta and I really love it! That’s just feedback and, moreover, a hint to other zwifters to avoid the same pitfall.

Thanks,
Christian.


(Christian Wiedmann [X] 50) #4

I think they just wanted to make configuration easier for those who have just the KICKR. Rather than selecting KICKR for both the power source and the trainer, you just select once.

I’m assuming they’ll change the configuration screen eventually to allow you to select power and trainer independently. Maybe it’ll automatically select the KICKR for power if you select it as trainer.