Garmin HRM Pro drops after update

I did all the updates today to 1.28.0 and unfortunately my new Garmin HRM Pro (that has been working flawlessly before the update) drops as soon as I start a ride. Everything looks good on the AppleTV app and in the companion app, but once the ride starts, the connection is lost. Battery on the Garmin is good. I have restarted the iPhone and the AppleTV to no avail. My Schoshe HRM armband works with no issues, but I would prefer to use the Garmin because of its accuracy. Anyone else having a problem? Any suggestions?

I have the same issue, except mine won’t even show up as connected in the pairing screen. I also changed batteries to make sure, but to no avail.

Let’s hope that more people are having the issue and report it, because that’s the only way anyone at Zwift seems to pay attention.

Heck, I’ve been dealing with resistance in rides being backwards for over three weeks and still haven’t seen anyone else saying they’re having the problem. Unfortunately, I’m always told that it’s a problem with my trainer despite my trainer being the only thing that HASN’T changed over the last few weeks…as opposed to multiple Zwift and Zwift Companion updates.

Hope this thread will get some resolution.

Similar problem with Garmin HRM-Dual dropouts with Zwift. During the ride it disconnects frequently and connects back. Using the latest Windows app. On the same machine Trainerroad works flawlessly with the same HR strap.

I think I have the same issue. I have spent hours and hours trying to sort this and had long chats with Zwift. I believe it is now with L2 support. I am having connection problems when running on ATV with a companion app on Android in general. This is also new for me as I used to do races ok with more than 2 devices (steering, HRM, power crank and controller) via the companion app. My Polar OH1 (when actually visible to connect), never stays connected for more than say 5 seconds. The weird thing is, it fails on a Android V10 and a different (bought new to hopefully resolve the issue) device - Android V11, however, It works ok on an old Android V8.1 dug out of a drawer! 8.1 is no longer supported?

I reported similar problems many months ago folowing a Zwift update (Apple TV, Neo 2T, Companion app bridge, Android 9 OS).

It was never resolved and I simply stopped using the ZC BT bridge (making my rather expensive Assioma Duo pedals a pretty useless appendage :grimacing:).

The thing that seemed to resolve it for me was to reinstall everything, both on the AppleTV and on the iPhone (Zwift and Companion). I have no idea what was broke, but doing the reinstalls fixed it.

Last night, I fought for 45 minutes with Bluetooth connection issues on the AppleTV. Again, uninstalled and reinstalled everything on the ATV and iPhone. Something is flakey and I am guessing that it is more to do with thw ATV than anything else.

Thanks, I tried that on ATV and my Android 10 phone, and on the new Android v11 tablet it was a clean install of ZC. None of this made any difference.