Game Update v1.44 [July 2023]

not sure why they are rolling it back. mine updated yesterday and everything worked fine. i did a femmes ride. tt race and and a short cool down. No bugs, everything worked just fine. windows

“limited reports of the game appearing black for some users

It’s acknowledged that not everyone is seeing the issue, but it’s enough of a showstopper that it’s necessary to roll back.


Taping to cycle through the cameras was a pain, but having a window popup and having to decipher the differences is a much bigger pain. I decided to not use alternative cameras because it’s such a pain now🤷🏻‍♂️. Maybe a long-press might be better on some level, or a wheel like motif (like old time odometers)?

The problem for me was I have a Magic Trackpad under my iPad on a stand, and the sweat would drip off my fingers and hand making the Trackpad go a little nuts, and cleaning it a necessity (ICK!)


All the “emotes” other than wave and elbow should be eliminated, camera could be tap to rotate and long press to open the list. Still too much wasted space with the stop button.

1 Like

Many screen shot in previous reply show the third person camera angle (number 1) having the avatar and bike too close (since the update) and not able to see the fire from my fire socks :sob:

Am I doing something wrong?

Edit: I am on MacOS on a Mac mini M2


May I gently suggest rolling back the ATV version as well?

I’ve posted a new thread here detailing issues I’ve had, including troubleshooting steps:

I see other sporadic reports of issues that I think are being conflated with Zwift Play/Companion app bugs but I’m suspicious they’re game bugs as I do not use the Companion for bridging, nor do I own a Zwift Play.

I might be wrong but I doubt that it’s possible to rollback the ATV due to the Zwift app not being in control of the update process, unlike on Windows.

1 Like

I would also make a request to have the drone view control changed. It is now quite annoying to move up and down in the view because the arrow keys call up the on screen menu ( up arrow ) or worse u turn ( down arrow). Can those controls be assigned elsewhere or have a secondary mapping?


I’ve also found that if you change camera views using the 1-10 buttons on Windows, the view that the action bar says you’re on doesn’t change if you have Zwift Play connected (which kind of makes sense because the Plays are supposed to be for all devices. I noticed this because I love drone camera and I still have to use the keyboard to control it; being able to do that with the Plays would be nice). Although I suppose this can be useful for moving to a different view for a second, then just pressing (on the Plays) uparrow A A to restore view.

Might not be possible to roll back, but it should be possible (if deemed necessary) to post a new version that is the same code as 1.43, and just call it 1.44.5, or something like that. I think.


AdZ today, Sunday 27-07, after finish top ring everybody jumps like crazy on that " sleeping policeman".

The ‘camera’ popup menu should have pictures and no text. There is something about having to read text like that that seems to get harder when I’m pushing hard. Plus pictures wouldn’t take up the whole screen. Just a thought…

1 Like

Updated Zwift Play Controllers after last ride, updated Zwift on my Mac today - Controllers will not connect. Zwift sees them connects for a second then disconnects.

Worked perfect till those updates.

No results in category, 1.43.3. Been an issue for several versions.


Any plans to roll back Android version as well? The roads on climb portals are still invisible - I tried it again and it is still the same as I reported earlier.

It is pity that what worked nicely before was broken in new version and is unusable …

@Martin_Skapa Thank you for reporting this - we’re investigating.

Since the update, I haven’t been able to start a session properly…
Worked OK last at the start of July but now it goes into the session, it says everything is connected - and that data is coming across from the HR monitor & Cadence sensor - but no movement/speed…

Setup is: Android tablet, Wahoo Kickr Rollr, Wahoo Tickr & Wahoo Cadence sensor…

Anyone else having this issue…?

Picking nits, possibly, but saw a couple avatars with solid green rectangles on their backs over the ‘pockets’ in the jersey. It was at an intersection in Watopia, and I caught them on a glance up as I made a right turn heading to ‘fishing village’. Minor issue for sure…

Getting jerked hard left with steering connected coming into the castle courtyard on RGV with Jaques this morning.

Everyone please note that v 1.44.2 is a Windows-only release.