Game Update 1.43 [June 2023]

FWIW I tried this today. All good when pairing directly with my phone.

However, I still couldn’t get both Play controllers to pair on Apple TV using Companion as a bridge. It was one or the other (although I could decide which one was paired successfully).

I’d guess it’s an Apple TV/Companion bridge problem rather than Play directly.

1 Like

AppleTV users - please note that a patch has been released to fix a crash. Please update in the App Store at your earliest convenience.

3 Likes

I’ve given up trying to use the Play controllers via Apple TV for now I think.

Today, I paired them first and that was fine. But them my HRM wouldn’t pair. Eventually when it did get recognised, the connection kept dropping.

In the end, I gave up trying to pair things via Companion, and just paired my trainer and HRM directly with the Apple TV.

It might be Companion or Android, I don’t know, but other Bluetooth connections to my phone were working fine.

That is what happened for me the last time I used them. Pinned to the left side without me touching them at all and autosteer wouldn’t pull me back to center. Just gave up. Fortunately it was 16 laps of downtown dolphin, so I hooked back up with the pack when they came around again (after getting ride of the Zwift Play, going to the pairing screen and activating my sterzo smart so that I could get back to the middle) and rode with them a lap down. Not a ton of fun knowing I was out of the race entirely, but it is what it is.

I had the same issues until I dedicated a router with only the Apple TV and the companion app. My eero mesh network wouldn’t maintain a constant connection to the companion app with the attached Bluetooth peripherals ( zwift play, heart rate monitor, and Tacx trainer). Also I am diligent in starting the companion app before Zwift loads up on the Apple TV

The issue with pairing via Companion as a Bluetooth bridge is being worked on with the highest priority. We’ll provide updates as we have news to deliver.

2 Likes

@Daren , I wanted to make sure that you weren’t running into a different bug where the Play may appear fully paired, but are only partially connected.

We’re also working this one out, but I would recommend doing the following, just to make sure that a separate bug is not affecting your experience:

  • Launch Zwift with your Play controllers powered off.
  • Pair your play controllers one at a time, allowing the Play battery level to appear in the battery icon on the pairing screen before continuing
2 Likes

I’ll try that, but yesterday I had an issue where both Play controllers paired fine, but my HRM wouldn’t (or sort of would, but intermittently). That made me feel like it wasn’t necessarily the Play controllers themselves.

This does seem to be a recent development though, because initially I had no problems at all. I’d guess if it’s the Play controllers it’s something introduced in the newer firmware or the 1.43 update.

I don’t know how to get any diagnostic information out of an Apple TV, unfortunately.

Screen froze again. This keeps happening almost everyday.

I’m using:
iPhone 11 Pro
iOS 16.5.1
Zwift version 1.43.0

I tried the video screenshot feature on 3 rides and all videos were missing audio… when exporting to Strava and all videos transferred to mobile (Android). Did I miss something?
Apple TV (A2737) / 1.43.2(114628)

@Steffen_Weege Would you mind sharing a link to the applicable Strava activity? Feel free to DM me if you’d prefer. I tested on mine just now (Apple TV + Companion on Android) and mine had audio both on my Android phone and on Strava.

Nice job describing pairing problem – my experience precisely. I’m running zwift on PC and using iPad as BT bridge.

PS – To Zwift tech staff. As a preference I would like the Plays to be a ‘turn on and forget’ install which would allow the Plays to auto pair from a sleep mode, which is how they worked before the last f/w update.

Hello @evan-zwift, here are three recent activities from Strava. Both without sound, one doesn’t even play fully.

strava. com/activities/9425452715
strava. com/activities/9424543880
strava. com/activities/9400057904
(An error occurred: Sorry, you can’t include links in your posts.) :shushing_face:

I did one of these today and I noticed that during the short video recording the game is silent, before and after everything is normal. I just wanted to mention it.

Thanks in advance!

Windows users please note this patch.

3 Likes

Thanks! I fell foul of the second one during a ride recently when trying to pair the controllers, so it’s good to see a fix so soon.

Does this fix problem with Play controllers continually dropping and reconnecting on Windows machine?

1 Like

@David_Hull_7k This set of fixes is specifically targeted at game freezes. In parallel, we’re working on improvements to connection reliability as a top priority and are targeting having additional improvements in the next game release as well.

2 Likes

A fix that just broke Zwift in my Zwift PC:

@enricoclaudio This may indicate that there’s a problem with one of the installation files. Please try the following:

Step 1: Ensure that Zwift Launcher / Zwift are closed

Step 2: Navigate to the Zwift installation location, likely C:\Program Files (x86)\Zwift\

Step 3: Locate and delete the following files:

  • Zwift_ver_cur.xml
  • Zwift_ver_cur_filename.txt
  • Zwift_[A BUNCH OF NUMBERS AND LETTERS HERE]_manifest.xml (note: the name of this file will vary depending on which version of Zwift you have installed currently; on mine, it’s called Zwift_1.0.114012_e483f71d_manifest.xml).

image

Step 4: Re-launch Zwift as you normally would; the updater should download new versions of those files and hopefully will mitigate this issue.

Please let me know if that doesn’t help; if not, a re-install will likely mitigate the issue, but may not be needed if deleting those specific files works for you.

Had to re-install and that fixed it. Thanks :pray: