Game Update 1.43 [June 2023]

It’s definitely harder to get the menu button to come up, I prefer the old behavior as I never use the on-screen action bar, only companion.

You are the eternal optimist! :joy:

I speculate it may be related to the changes they made to improve UI navigation with Play controllers

The game froze up ~30 minutes into the SISU Tour stage 1 today (8AM US EDT). Spinning beachball in macOS and had to force quit the app as it was “not responding”. That is not a common thing for me - I think it happened once last year. Companion app showed frozen metrics. I restarted the app and it tried to upload the data, which is viewable on The at Home Cycling & Running Virtual Training App but in Companion it can’t be viewed because “still in progress” which persists after restarting Companion.

I’m on ATV and an Android phone, and while I haven’t had any Play pairing problems, today Zwift refused to pair with my Wahoo Tickr.

I tried changing the battery in the HRM just in case it was that, but it didn’t help (and in any case, it was connecting fine with my Garmin over ANT+).

So not the same problem as you are having, but maybe a broader problem with Bluetooth connections.

A post was merged into an existing topic: Zwift Climb Portal [2023]

2 posts were split to a new topic: [Riders Nearby nameplate glitch AppleTV [1.43]

Hit the coffee break while riding alongside a robopacer. My rider latched onto some other riders leaving the robopacer behind and losing the drops multiplier.

2 Likes

@shooj I sent logs to support about this failure but they didn’t find anything useful. Please share with devs if you think there’s anything in there to learn. I’ve done several other rides using 1.43 before and after with no issues.

Has anyone mentioned the near impossibility of using the typing function while in the pens?

For some reason the typing screen doesn’t seem to have pure focus, so if you start typing things, it might take a letter as if its the hotkey and open up something like the garage or the sensor select screen.
It’s quite frustrating.

Also, not a fan of the action bar popping up all the time. I’m on PC, I have a full mouse and keyboard… I’m not playing on a tablet, and I don’t need an action bar. I have… a keyboard.

It’s super annoying having the action bar popping up all of the time and trying to take over what it is that I’m actually trying to do.

The action bar now means some other things can’t be used, like the “drone view” camera, doesn’t function properly due to the action bar wanting to take over my inputs.
Did ZHQ forget we already have arrow key keybinds??

Another steering bug report, hopefully narrowed down enough so as to be reproducible.

Hardware: Kickr Bike v1 with Zwift Play controllers. FW up to date on bike and controllers.
Steering works fine with the Play controllers until I (accidentally) hit the Kickr bike steering buttons often enough. Doesn’t happen immediately on first button press, but easy enough so I regularly trigger the bug accidentally, and I think I’m not particularly uncoordinated.
When the bug hits, my avatar gets glued to either the left or right edge of the lane (depending on which Kickr Bike steering button I hit last, I guess), and neither the Zwift Play steering buttons nor the Kickr bike steering buttons will move it left or right anymore. In other words, steering ceases to work. After about 2 miles, the Zwift Play steering buttons start working again.

I know that other Kickr Bike v1 users see this bug, too, but apparently not all of them, and the reports of this bug haven’t been acknowledged by Zwift so far, or I haven’t seen it. Could it be an A/B test cell that we’re either in or not in?

I suspect the bug would become irrelevant if Kickr Bike users could actually disable its steering buttons again?

Yeah, I’ve had that problem for ages. It’s not new with this update, anyway.

Didn’t always happen though. Sometimes I could type fine, other times not. IIRC I felt like it was related to something like the amount of chat or the number of people, but I never narrowed it down to anything specific.

Since having a screen freeze last month on 1.41 or 1.42 on Android Zwift app ,after trying to chat in the pens ~30secs before Tiny Race start and then having to “race” (finish in time for next Tiny Race) via the Companion app on another Android device, I very rarely try to chat via the Android app any more.

Once or twice since I’ve chatted in pens via the Android app, but it feels awfully laggy. On Xiaomi Mi A2.

Scratch that about not having any Play pairing problems.

Today my Tickr paired just fine, but the left Play controller wouldn’t pair. It was shown and selected in the pairing screen, but the blue Z just stayed flashing until the controller powered off. Waking it up and trying again didn’t help.

try unticking both controllers.

tick one and wait until you get the buzz to say it is connected, then tick the other one and wait to get the buzz then click close.

This works on android for me (PC seems fine however i pair them for now)

1 Like

I tried deselecting and reselecting it and other incantations, but I’ll try again next time. :ride_on:

you have to deselect both then just pair one at a time, make sure one is paired, wait about 10 seconds, then pair then other and wait another 10 seconds then click close.

works for me

I’m having this exact issue. Spent the first 3 minutes of a race pinned to the left. Eventually just powered the controllers down and tossed them to the side.

1 Like

Tried this, didn’t help. First the left one paired by the right one didn’t. I deselected them, left the pairing screen, went back in, and paired the right one; then the left one wouldn’t pair.

At least the right one worked though, as it’s the more useful one while riding.

Are you able to try them on a different device to see if they’ll pair to anything? like a phone or something?

This is via my phone as I’m on Apple TV and using Zwift Companion as a bridge. Admittedly I haven’t tried pairing them directly, because if I do that I can’t pair my HRM or trainer. =)