Game Update 1.39 [May 2023]

it is caused by zwift, i bet this is not the only phone with this problem after update
if i try Aurora Store open source google play frontend and set my phone to Galaxy 9+(3 years older than my current device and slower) i can install zwift but i’m not interested in running it this way

What happens if you set it to your Poco phone in the aurora settings?

it wont install correctly, will only download 18mbyte segment and not the whole app, it is evidently not available for my Poco, same as with Google play store

Please go to the Google play store app settings accessible from the phone settings menu and delete cache and data and then try again to install zwift.

And restart you phone if you haven’t done it for a while.

thats pretty generic advice and it wont work in this case, i’ve already tried, problem is not on my side but in Zwift app manifest on Google Play

Raise it with Zwift support if you haven’t already done so. You’re unlikely to get this resolved here on the forum.

1 Like

i did, zwift support dont care

Add to your list:

  1. Crashing if you look at or scroll through the leaderboards after an event/race (reported by lots of people, also in this thread, and here).
  2. Whenever Zwift has crashed (for example, due to the issue above…) and you restart Zwift, the pairing screen won’t find the ANT dongle, unless you shut down Zwift and launch it another time.
  3. The avatar won’t spin his/her legs if you join the pacer bots. (reported by lots of people, also in this thread)
  4. Keyboard arrows don’t work for navigation (directions, U turns) and several other functions, as reported by many others e.g. here.

PS. I have a video of all the first three issues (in the same order as listed above, at 29:45, 31:05 and 33:10–34:52, respectively). All issues have happened repeatedly after the last update.
(Sorry about the grin in my face, the race was terribly hard!)
This is on a MacBook with a proper dedicated external GPU (Radeon RX 580), macOS Ventura 13.3.1 and Zwift v.1.39.

1 Like

Will there be a resolution for Apple TV remote NOT being able to access the blue action bar at all? Since the update, I cannot access that. Thank you so much!!! Have a great day!

I found another three bugs, this time with the sprint jersey (maybe affecting all jerseys…?)

In a pace partner ride in Makuri Island I was able to achieve a sprint jersey.

My avatar wore the jersey but there was no small jersey besides my name in the riders list on the right of the screen.


That’s me on the left of the screen in the green jersey

Other rider wearing green jerseys had no jersey icon besides their name, too.

Another guy who snagged a green jersey just in front of me asked me if I had no green jersey icon, too.

————————————————————————

We all know that for whatever reason while riding through a world you will be stripped out of your (sprint) jersey and get your normal jersey back. Maybe if you are going in the other direction.
But now the little green jersey beside my name in the list showed up again…but now I had TWO little jerseys. I am pretty shure that I had just one at this moment.


This picture was taken just moments after the other picture above.

——————————————————————————————

There were no automatic screenshots saved in the moment of achievement.

Was there a change to fix apple watch pairing with this release?

I didn’t read it in the release notes, but it’s discussed here in this video:

1.40 is out

1 Like

0_p32JLrxCXtk3pF6O

11 Likes

Awesome!
Not sure it’s helpful, but wanted to share that I just checked screenshots of rides where I had the issue, and it seems that every single time there’s another rider with steering enabled in the group.
It may be that the issue became less noticeable for a while because people with steering-capable hardware trained themselves to turn steering off. I know I did.
That fixed it for folks who turned it off, but also for others who left it on because the odds of being in a group with another rider with steering on went down.

Version 1.40 seems to have resolved issues 3 and 4 (can join a Pace partner and find my avatar’s legs spin like normal, and the keyboard arrows work for navigation purposes). I haven’t tested the race leaderboards yet.

I see the same issue intermittently - mac desktop setup, run via ios companion. Seems the legs start going when there’s a scene-change in the game (intersection, waypoint, banner) or after several minutes into a ride (haven’t timed it ~5ish maybe?). Cadence and power are correct, appears just the avatar animation that’s coasting…

I’m riding the kickr bike and since 1.39 and 1.40 I’ve noticed 2 new things. Steering is selected in the drop down and usable in the event but I can’t deselect it where i could prior to 1.39. 2nd during an event, race or group ride, my avatar periodically is way wide to the right of the group and out of the draft. Just me. If I don’t hit the steering button to rejoin I’ll get dropped. I don’t know if that’s PD4 or the bike but it just started happening. I typically don’t see any other nearby riders with steering so I’m thinking some steering control signal is incorrectly generating or interpreted. I’d rather turn steering off. will that be possible in future or am I just not seeing how to do it?

1 Like

So yesterday I launch the app and the steering is off. I left it off and normal drafting returned. I turned it on after the event to test that it worked and it did. Today it was still on by default and I did a race with it on and the drifting wide was back. I kept correcting it so no problem but it feels kind of weird where no one else has steering and I’m clearly using mine. Sort of like a power up no one else can have. After it was over I was able to toggle it off and on so it functions the way I thought it would leaving me wondering what exactly I was clicking previously that didn’t. The drafting weirdness may be a Wahoo thing. Now that I can turn it off I’m good. If i enter a steering only event and everyone drifts wide right, no problem.

2 issues for me - 1, joined a pace partner ride and the screen scooting around while it was ‘finding’ the partner, which never happened. 3 attempts later and I finally joined. I also turned off early and the course profile said I had 278km remaining on Tempus Fugit :joy: luckily I only wanted a 10 min cooldown!

2, the menu button is half on/half off screen. I can push it, but it’s super low. It’s def moved.