FPS


(The Penski) #1

Checking my FPS shows something strange. All the views (all 1 through 9 EXCEPT 8(the helicopter one)) shows FPS to be locked at 30. The helicopter view (8) seems to be locked at 60.

Is this normal?

PS Advanced graphics settings would be useful.


(Steve Clogg (LEAD)) #2

You are just seeing the vysnc effect. If you setup drops below 60 fps it will drop to half the refresh rate.

Look for the vsync option in your graphics card options, you can try various settings like on/off adaptive etc. Turning vsync off will make the scrolling less smooth on direction changes like corners. 

Just try the different options and see which one you like best.


(Robin Wehrs) #3

How do you check the FPS?

I tried fraps but it gave me very strange low fps. Strange because 12 fps on a GT 640 and the same on a GTX 560. Performance of the cards are much different.


(The Penski) #4

I used FRAPS.

 

What Steve is saying seems to be correct. I haven’t seen this behaviour in a game before (having gamed a lot, though not recently to be fair).

I played around with the settings to see how they would impact quality & performance. Setting anisotropic filtering higher improved the graphics quality, but did not impact performance much (its hard to tell when the FPS is being limited). A good change was setting the resolution higher to 1920x1080, this reduced the ‘jagged’ edges of lines and I guess reduces the need for anti-aliasing. Next I will try matching it exactly to my monitors native (1920x1200, 16:10)

What had a large impact on FPS for me was the shadow texture resolution - changing it from 1024x1024 to 2048x2048 resulted in a considerable drop.

My machine is 4 years old, I’ve got an i5 3.3ghz and GTX 570.