"Error Publishing Event" when updating club event in Companion App

I tried to update one of my club’s event in the Zwift Companion app today but when I clicked the Publish Event button, I got this error:

Error Publishing Event. Error: Request Failed With Status Code 400.

I tried multiple times with both my phone and my tablet, and I keep getting the error. I have done this numerous times before, so I’m certain I’m not doing anything wrong.

Is this just a temporary issue that will be fixed later today?

If the event is inside 60mins from start you get this error.

Thank you Dejan, but that not is it the case here. The event I’m trying to change is 5 days from now.

I tried agin this morning and I’m still getting the error.

Strangely, I just tried changing another event and it worked. I just can’t change one of them. But I don’t know why. All I’m doing is changing the route and number of laps.

You might try editing it via the web UI instead of Companion and see if that helps.

If Zwift’s client (Companion) talking to Zwift’s backend service is getting a 400 error (bad request) that sounds like a bug so if you want it fixed you should probably contact support.

Thanks Paul. I tried editing through web UI but I got the same error 400. Sigh. I guess I have to reach out to support.

1 Like

I fixed it! Here’s how:

I turned on the browser’s Developer Tools and found this error message in the HTTP response body:

{“key”:“Pace value can’t be larger than 5.000000w/kg in subgroup 5186918.”}

It turns out that, somehow, the Category A group in the race had a w/KG range of 4-6. I don’t know how that happened. I never changed it from when the event was originally created. To fix it, I changed the range to 4-5.


I am trying to update my weekly races and when I publish them I get an Error 400.

I have also noticed that the event information has not been updated although the Zwift Admin team advised that the updates had been completed.

Searching through forums there are a couple of similar posts but no resolution.

I just checked and mine it is the same, 4.2 - 6.4. I’ll make the adjustments and see if it works.

Tks for info…

1 Like