Custom workout does not update with changes when syncing

Seems like my synchronization of custom workouts are a bit unstable between my PC and my IOS devices (ATV and IPhone). This is what is happening:
-I have a custom workout that I modify (power modification) on my PC.
-Everytime I update the workout on the PC I also start the same training session on the same device to make sure it was updated.
-When I then go to my Apple TV or IPhone I experience that from time to time the same custom workout was not updated with the latest changes.

Has anyone experienced the same and is there a way to force the sync to happen?

Yes. Same issue. Just started occurring in the last week or so. I’ve edited custom workouts on my PC, successfully saved them (which I’ve confirmed by logging out and then back in to ensure the changes are still visible), however, the changes are not showing up on my mobile device (ios). Tried numerous times. Updated iOS Zwift app, etc. The old versions of my custom workouts are still visible on mobile, but not the newly edited versions. I’ve successfully edited custom workout without issue in the past. But sync doesn’t seem to be working anymore.

1 Like

Oddly enough, I think I just found a solution. I created a new custom workout (just called “Sync test”) on my PC. Then closed and reopened the Zwift app on mobile, and there was the new “Sync Test” workout along with the edited versions of my other custom workouts. I can only guess that the sync feature is being triggered by looking for a new workout, not an edited version of an existing one. If the software doesn’t “see” a new workout, it’s bypasses the sync function. I didn’t experiment with simply changing the name of an existing workout to see if it triggers a sync, but that might work as well. Otherwise, just create some bogus placeholder workout, let it sync, then you can always just delete the placeholder.


As one final note, I now re-name my custom workouts after editing them (i.e., Custom Workout Rev 1, 2, etc.). This ensures they sync properly to the mobile device


Yes. Same issue but after reading some of the replies here, I did find that editing the title of the workout did trigger a sync across all devices. Suggest that each time you edit it you add something like ‘v1.1’ to the title…

Super tip, that did it for me - was going nuts :slight_smile:

Hello all,

I’ve marked @Vinz_Clortho 's post as the solution to this issue, but I will flag this up for investigation. For now, I recommend either renaming a workout or creating a duplicate if you want updates to the workout to sync across devices.

I am pooling similar-sounding custom workout issues together in another thread here. If you’re creating or importing custom .zwo files that are not appearing in Zwift, please join the discussion so we can get to the bottom of this issue.