Can't find Wahoo Direct Connect [Android] [March 2022]

As far as I can tell, it is not working with Android. As I am normally a PC user, will have to wait for the PC update.

1 Like

Thanks for reporting in. Looking at your log files on the server - I’m seeing that you’re able to connect to the Android over regular Bluetooth, but there’s no record that the Direct Connect was ever involved.

If the Direct Connect is not found - it may not be connected to your WiFi network correctly.

  • Is the WDC unit set up on your local network according to Wahoo’s instructions?
    If yes - is your WDC and your Android connected to the same WiFi station ID?
  • Your Android can’t be using its data plan to connect to the internet. It’s got to be on your WiFi signal. Please verify?
  • Some routers have a “Guest” network SSID in addition to the regular SSID. If your Android is on one and the Direct Connect is on the other, they won’t be able to see each other.
  • If your Android is running a VPN app - it will not be able to see the Direct Connect. Please disable the VPN
  • If your Android is running a firewall app - you’ll need to configure the firewall to allow connections on port 36866.

@shooj I’m seeing the same issue as @Mike_Squillace . I’ve tried both from my Android tablet and phone.

-Wahoo Fitness app on phone confirms WDC is Discoverable
-Tablet and Phone is on WiFi and the same subnet as the WDC
-Guest SSID is not in use
-No VPN apps
-No Firewall apps

Tip for troubleshooting DIRCON:

  • Install Discovery - DNS-SD Browser app on iOS/macOS and look for _wahoo-fitness-tnp._tcp (it’ll be down the bottom of the list). If it shows up you can click on it to view IP details. A ping test also works.

  • Windows users - Google for “Bonjour browser” or something similar (from a reputable source).

If you can’t see the _wahoo-fitness-tnp._tcp entry, there’s a problem.


I can confirm Bonjour browser on Windows shows my DIRCON on _wahoo-fitness-tnp_tcp. at
Windows PC on WiFi:
Samsung Galaxy S20 Plus on WiFi:

Zwift on the Galaxy still not listing the DIRCON, only Bluetooth and ANT+

Asus RT-AX58U router.

I can confirm my DIRCON works fine on AppleTV, but still not showing on my Android phone or tablet.

1 Like

Setup according Wahoo’s Instructions. Direct Connect works with Wahoo app. Phone on WIFI same SSD. Android is not running a VPN app. Android not running a firewall.

Thanks for verifying @Mike_Squillace we’re digging into it.

UPDATE: We are able to reproduce on Android 11 and 12, and are working on a fix for this ASAP.

If anyone is using Android 10 or older - please let us know that it’s working as expected (or not). Thank you.

1 Like

The fix for Android pairing to Direct Connect will be in the next game release. We appreciate your patience on this, folks.


excellent, thanks. Any idea when that will be available?

I see the advertisiment, on zwift I see also the device

but it never shows a metric.
Looking on wireshark i never see a tcp connection to the advertised port.
My device works with RGT and Wahoo app.

I’m not familiar with Wireshark, but assuming you’re running it on your Mac? If it can’t see your WDC on the network - check the macOS firewall settings and disable it if necessary.

See the Wahoo Support site for more help on this issue. They talk about Windows firewall settings and don’t say anything abut macOS, but the same things applies to Macs.

Thanks for answering me.
Yes i’m on Mac.
It’s not a issue of WDC because it works fine with RGT and Wahoo app as I described above.
It has for sure a wrong implementation of the DIRCON protocol on Zwift, I checked the Zwift log and it saw correctly the ip and the port of the WDC but it never try to create a TCP connection. Is there a way to increase the verbosity of the zwift log? Can I talk to a 2nd level support on Zwift?

So when is the update? It was advertised it would be working and no update for over a week

I works now, for me at least, on Android 9 and the new Zwift 1.24.0.

Works like a charm now :smiley:

Is it still working for you? After the last update dircon does not show up for me on Windows 10.

Using Wireshark there is never any data from the ip of the Wahoo dircon adapter. There appears to be broadcasts looking for it but perhaps they are malformed?

Dircon works for me on both Android and iOS.

No change when I turn off Windows Firewall.

As of yesterday still working fine but now on windows 11.

With the release of Zwift game version 1.24.x - the specific Android issues in this thread have been resolved.
If you are having issues seeing the Direct Connect on your Android device - please

  1. visit the Play store and be sure you’ve updated to the latest version of Zwift
  1. Please check Wahoo’s instructions for proper setup?
  1. join us on the April 2022 thread about the WDC here.

I’m going to lock this thread now.