Black Celebration Jersey missing in garage

I haven’t updated for a long time, lol.

Thanks for reporting back. I did see that you competed last night’s BCS ride, so was thinking the kit would appear after you updated.

There are more rides all month. Would you be willing to do another to get the kit?

Absolutely! Hopefully, it will work next time. Thanks for getting back to me.

1 Like

I haven’t gotten my jersey either.

I updated my app in my ipad, and it still didn’t show up in the garage, but I’m going to do another ride today and see what happens. Those jerseys are AWESOME looking!

1 Like

I don’t seem to have received my jersey either after completing today’s BCN ride. I’ve done an app update but still isn’t showing.

@Shannon_Davis_BGDB @Andy_Thompson3
I’m assuming both of you have updated to latest version of the app for whatever OS you’re running the game on?

The kit will not show in your garage until you save & exit, and log back into the game.

With mobile OS’es in particular - swiping the app into the background does not end your session. You must “save & exit” at the end for your session to upload correctly to Zwift’s servers. Is that how both of you are ending your rides/runs?

Thanks for the reply. Yes, all up to date and fully exited. Tried going in and out a few times and restarting phone but the kit just doesn’t seem to appear. Because of other commitments I’m probably unlikely to another of the celebration series.

I always save and exit the app on my ipad after every ride…it’s how it’s uploaded to Strava, so not sure what’s going on. Are you getting others that haven’t been able to access the kit?

I dug deeper in your ride. I see you completed this event this morning and got credit for the Mighty Metropolitan badge.

However your iPhone was using version 1.0.58982. If you go to the App store and you should see an “Update” button that will bring you up to v 1.0.61590.

1 Like

Yeah when I did the ride it must have been that version but I saw in your reply to someone else about the update which I’ve done this afternoon, some other kit items came through but not this celebration series jersey.

I checked your latest sessions on our server, and both your iPad and iPhone are an older version 1.0.60640 the last times you logged in. Please visit the App Store using the link above and update.

For everyone reading along - while there are legitimate reasons to set your devices to not auto-update - we advise you do in order to avoid these sort of issues.

1 Like

I’ve started a ticket so we can track any other reports of this.
So far, all three of you reporting this are on iOS devices.
Everyone: please continue to report this, especially if your computer is something besides iOS.

1 Like

@Mark_Crane_TOG_G_65y Remember our discussion about weird stuff happening after an update? Give this thread a read. :man_facepalming:t2:


@shooj my iPhone is updated. As a matter of fact, I show the update for my iPhone yesterday and my iPad isn’t showing any updates for Zwift. :woman_shrugging:

In this case, it would seem to be mostly because iOS users are not required to update the app automatically upon start up. I’ve never been able to bypass an update in the windows application. There’s plenty of weird stuff going on with the last coupla Win10 updates… :crazy_face:

I think that would be a step forward, forcing updates before being able to log in. But we’re talking about folks still using the game version from November! :rofl:


To get over that, on Apple TV I always launch Zwift from the App Store. So I either see an “Update” button or an “Open” button.


Yay! I updated my app on my ipad and all is well. In fact, this evening’s ride, everyone had the kit on. Tuesday’s ride, everyone was just in orange. Also, someone commented later in this thread about update alerts not showing up on older ipads, etc. That is definitely the case for me. I didn’t even know I need to update something, and my apologies there! Usually, when I log on, if there is an update, it would just do it, but for some reason, I missed a few…Thanks! The kit is on FIYA! I love it!


Thank you for coming back to let us know it worked out the way it’s supposed to!