Zwift on Linux, Using Lutris & WINE

Zwift is supported on Linux by Lutris.

Lutris is an Open Source gaming platform for Linux. It installs and launches games so you can start playing without the hassle of setting up your games.

The Zwift setup page is here. It says:

During Installation:
After the Zwift installer downloads, you’ll be greeted by a white screen. Quit the launcher, including from the wine system tray

After Installation
Zwift requires the launcher to be running at all times. Select “Run EXE inside wine prefix” and select “drive_c/Program Files (x86)/Zwift/ZwiftLauncher.exe”. Once it’s running you can hit “Play”.

@James_Joy1 reports:

interesting, i haven’t heard of lutris before. it looks like it’s a way to distribute custom wine configurations?

from the install script (Lutris - Open Gaming Platform), you can see that it’s doing the same “run from process” trick that this thread pointed out.

so my guess is that connecting directly to your trainer/HRM/cadence/etc probably doesn’t work, but it CAN pair with your companion app. i’m still holding out to be able to pair directly, preferably (for me anyway) over bluetooth.

Yes, I managed to install & run smoothly without any problem. Make sure you installed Wine too.

1 Like

Hi, only just heard of Ubuntu and Linux and lutris today for the first time. Can anyone tell me, is it legal? And is downloading zwift by this method legal etc? Not trying to be difficult, just genuine questions as this is all completely new to me. Windows 7 gave up on me so looking into alternative!

yes it’s legal. linux is a computer operating system like windows, and Ubuntu and lutris are “flavors” of Linux. “wine” is a piece of software that lets Linux pretend to be windows so that toy can install windows programs on Linux.

ubuntu is a relatively easy way to get into Linux, but there is definitely a steep learning curve, so know that if you go that route it can be challenging.

1 Like

Thanks for the reply Dan, I tried getting it to work but not sure what I did wrong. I don’t think I’m tech savvy enough for Linux lol

ZwiftInsider on How To Run Zwift on Linux:

And here’s a detailed post on Slowtwitch:


I installed lutris too and later I tryed to install Zwift from the Lutirs Webpage. But my Installation stops.

Does anybody know what I have to do to get Zwift installed on my Ubuntu 20.04?

Greetings Nixdorf

I use fedora with wine
when i run the launcher i got zwift error

i run the installation first

Hi, I had solved the issue, removing anaconda and installing wine dependencies.

I tried Lutris and docker image too. It was working great till I got into ANT+ connection problem on my phone.

I solved my problem using WMware virtualisation for now, ANT+ dongle and some pretty fast CPU and GPU. I currently have 8G and 3D support in VMware turned on. It works somehow, still there are some graphic glitches but for my use it’s ok.

Hope someone finds this usefull.


I am trying to install Zwift (Ubuntu 22.04.3), and its dependencies, one of which is Microsoft WebView2. I did the install through Lutris and everytime it fails related to “Installing Microsoft Webview2 Runtime”.
It downloads and the WebView2 splash screen says, “Installing Microsoft Edge WebView2 Runtime”. After over an hour of waiting it eventually gives an error message about not installing. At this point nothing else happens and I have to give up the install by clicking Abort Lutris.

Thanks for your help.

This might save you some effort

Its been ages but thanks you for your help.
I try with docker but i have still a problem when running it

2024-01-18 20:43:00 0050:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
2024-01-18 20:43:00 0050:err:winediag:nodrv_CreateWindow L"The explorer process failed to start."
2024-01-18 20:43:00 0050:err:systray:initialize_systray Could not create tray window

Full docker log is here:

I prefer a white wine with Zwift in the afternoon. But, definitely a red with Zwift in the evening.