Zwift Companion app on iOS16 won't connect [September 2022] [SOLVED]

Hi, I’ve had the same failure to connect with the Companion since upgrading to iPhone 14 pro in March. I will wait for the new release, but if it is delayed or doesn’t fix the problem then I will want the test build. Thanks!

I haven’t seen anything to suggest that this won’t be May 31st.

Add me to the list.
Can’t establish connection between Zwift and ZC.
Zwift version 1.1.8 (1) running on MacBook Air M1 (macOS 13.3.1 (a))
ZC version 3.46.0 running on iPhone 14 Pro (iOS 16.5)
I have Netif “en0”.

Zwift is a worthless product for me without a stable connection between Z and ZC, so I hope the fix works for me as well.

The fact that you have an en0 interface name means that the update may not help you. The problem is probably something else.

Great, thanks

Hello all,

With the release of Zwift Companion version 3.47.0 today on the App Store, this issue should now be resolved.

Please make sure that you update to the latest version of Zwift Companion, log into the same account on both your Zwift and ZC devices, and confirm that both devices are on the same wifi network and the connection should start right up.

1 Like

Does it have to be Wifi? My PC is hardwired to my network. I installed the update (my iPhone 14 Pro is en2) and I’m not getting the in-ride view.

It doesn’t have to be using the same connection medium, but depending on the design of your network you could run into problems that you could rule out by making sure that both are exactly the same.

My tests of the new (pre-release) version of Companion showed that it also supports connecting the phone via Ethernet, in case you are interested in doing that.

Hi @Javier_Rinaldi, if your PC is connected via ethernet through your wifi router, then your ZC device should be able to connect over wifi. If that setup is not currently working for you, I recommend a reboot of your network and devices. I’ll be happy to troubleshoot this and make sure no new issues have come up.

I have rebooted the phone, pc and router. The about page on the ZCA app has my connection as en0, which is quite incorrect.

The zwift log is attempting to connect to a phone with an internal ip address that my router tmhas not assigned.

1 Like

That connection info looks like Zwift Companion is not connecting over wifi (or ethernet, if you have a compatible dongle). I recommend checking to make sure whether Wifi Assist/Low Data mode is turned on. If it is, you can either disable that or turn the phone onto Airplane mode to force ZC to connect to Zwift servers over wifi.

I’ve checked all those settings with no difference and the app is connected because I can view and join events.

Zwift Companion can connect to the internet over mobile data, which will allow you to view and join events. However, ZC can only connect to Zwift (in order to show map location, action bar, and dashboard) over a wifi connection. I don’t think that you’re experiencing the bug from this main thread, so I’ll open up a direct message for us to troubleshoot further.

Rowdy, I experiencing the issue on this thread. Which started when I acquired an iPhone 14 pro, i had a ticket months ago which was closed bt zwift support. With cellular data off (along with low data mode, wifi assist) the ZCA allows me to do what I described above. On the same network my ipad can connect to zwift. The difference is my ipad in en0 and my phone en2.

Have you updated to the latest version?

Yes, I did state as much in my first message and you can see the version number in the screenshot.


As with Javier - I was experiencing precisely the issue described in this thread - loss of connectivity as soon as I purchased an iPhone14 Pro. Unfortunately the new release has not corrected the problem. For the avoidance of any doubt I have deleted the ZC app and re-installed it - I am on App Version 3.47.0 (1478). I have also deleted and reinstalled Zwift on my iMac. I have re-booted my router. I have gone in and out of airplane mode on my iPhone 14 Pro to try to force a connection. I am definitely on the same wifi network and am not in wifi assist / low data mode.

My ZC app “about” info on my iPhone 14 Pro is as follows:

App Version: 3.47.0 (1478)
Server Version: 1.326.0
Connection Info: (en0)

I tried the ZC app on an old broken iPhone 7 and it connects up with Zwift immediately - the “about” info on the iPhone 7 ZC app is as follows:

App Version: 3.47.0 (1478)
Server Version: 1.326.0
Connection Info: (en0) (i.e. the correct local address that I can see on my router).

We still have what looks like an iPhone 14 specific problem,

Is there any further information that I can give you to assist in rectifying this problem?



1 Like

One further piece of information…

I downloaded network tools by keepsolid and can confirm that my iPhone14 Pro which does not connect to Zwift comes up as netif = en2. The old broken iPhone 7 that does connect comes up as netif = en0.

I have experienced the same issue. Switched to an IPhone 14Pro in March and couldn’t get Zwift Companion to connect. I’ve been following this thread and was excited to update to the latest version hoping that it would work again. After updating last night, I tried connecting this morning on my ride. Again no luck. I went in and out of the App multiple times, confirmed I was on the same WiFi network and still no luck.

I’m pretty disappointed as from all accounts it looked like Zwift had the problem fixed.

Let’s hope they can figure it out soon. I miss being able to use the App on my daily rides.


(not tried it yet)