Zwift App Does Not Launch

Using my Windows 10 PC, and first used Zwift last February, but suspended my account over the summer months. Now that I am attempting to use it again, every time I log in to the app, it immediately displays a screen which says, “Oops, something went wrong. We can’t find the page you are looking for. An error occurred, please login again through your application”.

I have uninstalled the application, and then downloaded and re-installed it. Let it spend 10 minutes updating and then when it prompts me to login, the same happens again. I know that my login credentials are correct, as I am able to login to the website and the forum using the same user name and password.

I’ve also attempted to create a new account from the app login screen, but I get the same result.

Can anyone help, please ??


Paul, I don’t think it’s an account issue as I’m receiving the same error but only when I try to log in from my laptop - the app works fine on my iPad. I, too, have tried uninstalling and reinstalling multiple times but that hasn’t worked. Did you solve your issue and, if so, how? Has anyone else experienced this issue?

No, still the same on my PC and I get the same message. Works OK on my Win 10 laptop. I have no idea why it won’t work on my PC. The strange thing is that I can log in to these forums using the same credentials, but it won’t open the app.