Wahoo Kickr & Climb out of sync with Zwift course gradient changes

I’m having the same out of sync issue. It worked perfect the first time I used it and hasn’t been right since. I pair the climber to my kickr before every ride. It makes no difference. It seems to go up or down randomly and never in sync with the course

Pairing hasn’t helped me

What do you mean by ‘resynced’? What’s the procedure for this?

I’ve had this issue a few times. Worst time was climbing ven top. Also had on Alpe Du Zwift. Really annoying. I was still at 10% half way down the descent. Seems to sort it self out when We start a fresh ride.

I am having the same issue all of a sudden. Is there a fix for this?

I have tried several options. First I updated the firmware for the kickr. It worked fine for one ride. I have to calibrate every time now before a ride. Even the calibration doesn’t fix the issue every time. Yesterday I had to result to not using Apple TV and have to Zwift using just my iPhone. The Kickr wasn’t responding to the gradient at all using Apple TV. Using my phone responded perfectly, with no issues, so the Kickr is working fine. I tried moving the Apple TV box closer to the Kickr, still no better. I am thinking of changing over to Zwifting using my Macbook and using the USB to ANT+ connection. I’m reluctant to do this because when the Apple TV box works, it’s so easy to use and the graphics are top-notch. This issue has become worse since all of the current updates. Zwift needs to look into this, or Wahoo does. Is anyone else is having issues with gradient lag? I’m not talking about a couple of seconds. I have climbed Alpe Du Zwift in the past and was still climbing at what felt like 11% when I had fully descended the mountain. The descent can take nearly five minutes. This issue is so annoying and has stopped me from joining group rides. until I get this problem sorted. One other option is to ensure that the iPhone using the companion app and the Apple TV box are both connected to the internet connection. Mine always are, so not sure this is a solution. I’d be gratetful for any help from others with this issue.

1 Like

I’m having the same problem. I was literally standing up in my lowest gear on an -11% descent. I am using kickr and AppleTV. I have only had the kickr for 10 days and my initial excitement has turned to sheer frustration. I’ll likely return it unless I can find a solution.

Perhaps they should cut the YouTube ad budget and fix their product.

This has become a significant problem for me now. 80% of my rides this seems to occur. Same hardware. Apple TV 4K, Wahoo Kickr using the Companion app.

All apps and firmwares are up to date, I do regular spin downs, I unplug the trainer after a ride and also restart the Apple TV versus sleep mode. Nothing seems to work. Anyone find a solution yet?

I turned off Bluetooth on the ipad and then back on and then reconnected to the kickr and the gradient sync with the climb has worked fine since.

only thing that worked for me was to downgrade the firmware on my Kickr core

1 Like

@Mark_Robbo How did you do that and into which version?

I downgraded to 1.1.1 but this hasn’t helped. In SIM mode resistance is absolutely not following the gradient. I am furious.

1.0.13 Is the version that you need to change back to

I just got a brand new kickr5, worked great for 5 rides, but today I had the awful 30 seconds out of sync with respect to cadence and power output displayed in zwift, and resistance of the kickr. I hadn’t rebooted my laptop for a week or so, but will try rebooting prior to next ride. Zwift did update itself at some point in the last week. But the kickr firmware has not been updated since I unboxed it and first set it up. Not sure if rebooting the laptop this will fix it for next use, but shouldn’t have to. I’d like to understand what causes this and what Zwift are doing to investigate. Do Zwift monitor these forums or do we have to report the issue?

Edit: Looks like Zwift is aware of the issue, they’re tracking a post titled: Wahoo KICKR reversed gradient [October 2021]

I’ve seen this issue off and on ever since I got my kickr v5 last year. It’s super annoying, you can’t pace your efforts anymore. On flatter maps it may take a few minutes to realize it’s not my imagination. At that point I often have to just deal with it because I only have 30 minutes or so to workout.

Exiting out of Zwift and restarting the app fixes it, when it does happen. I have the latest app updates and the latest trainer firmware. It feels like it’s definitely zwift that’s the problem. The grade changes work fine, it’s just not in sync with what’s on the screen. The power numbers are accurate and it looks as if the displayed power and the displayed grade is used to calculate the displayed speed, but the resistance is for some other grade.

It’s super disorienting. Zwift team, please fix!!

Hi all does anyone else have the feeling the companion app when syncing all you inputs I.E. cadence, speed, heart rate, and kicker that this is somehow miss matched and there for causing this gradient issue because I’ve experienced the reverse grade as well as feeling the whole ride was one third more difficult. I’ve noticed that in the game when I’ve gone to the settings bellow the garage icon the power settings mode is unhighlighted and states no speed sensor paired. Could this have something to do with it all?

I had this same issue today. I’m using a brand new Kickr Core (got it last week) and an AppleTV 4th gen. On today’s free ride I was 30 to 45 seconds behind what I saw on screen, at least. My climbs wouldn’t even start until I was on the descent sometimes. It was extremely frustrating.

I, too, have been experiencing this issue. I use:

  1. KICKR smart trainer
  2. Zwift on AppleTV
  3. Zwift Companion on iOS 15.1.1 for All sensors (KICKR, TICKR X, RPM Cadence).

See Wahoo Kickr Core 1.1.1 firmware issues and downgrade your Kickr firmware.

Thanks! Now I just need to figure out how to do that. I appreciate the response!