No movement when I want to start a workout? [April 12, 2024] [Android GV 1.62]

Hey guys,

Until last Saterday my set up with Android tablet and Zwift hub worked perfectly. Now no movement when I want to start a workout. Tablet says in bluetooth screen that hub is connected, blue light on hub is on.
How to get started?

Any idea?

Hi @Remko_van_Lun, welcome to the forums. Dont pair the trainer to the tablet on the bluetooth screen, “forget” the trainer on the tablet and then start Zwift. Let Zwift find the trainer and it should pair as power source and resistance.

Hi ,


Strange thing is that Zwift app says the devices (trainer/power sources and resistance) are paired/connected. I’m visually on the track. The blue light on the trainer burns constantly and when I start cycling (with resistance) nothing happens. I stay at the side of the road.

More strange was that all worked properly untill last friday

Who can help me out?

If you pedal the bike while on the pairing screen, do you see any Watts or does it remain at zero?

You also have the option of pairing the trainer via the Companion app on your phone (the “pair through phone” option on the pairing screen). This would use Bluetooth on the phone and bridge the connection to the tablet via WiFi, eliminating any possible issue with Bluetooth on the tablet.

It’s also possible that the trainer is faulty. If you want to explore that I suggest contacting Zwift support directly. Be very persistent when talking to the chat bot and continue with that until it lets you file a support request.

1 Like

Hi everyone. I’m Juan from Zwift. Thanks for your suggestions.

Dear @Remko_van_Lun, I took a look at your most recent activity and saw that you could complete a workout today (April 12). I hope you don’t mind confirming if everything is fine.

In case you need further help, please contact us to provide you one-on-one assistance. My colleagues will be delighted to help.