Garmin HRM no signal [SOLVED]

Today when I logged on to Zwift I was unable to pair my HRM pro to my iPhone via Bluetooth. Either it connects and stays at zero or it says “no signal.” However it connected to my Garming Forunner 945 without issue. I ended up doing the workout and just logging all of my HR information in Garmin connect. After reading through this thread I tried connecting my HRM pro to my wife’s iPad and it worked fine. I’ve been using my HRM pro on my iPhone for months and it suddenly doesn’t work. What’s going on? It was working fine yesterday.

*The problem may actually be beyond Zwift because I cant even connect the HRM Pro to my iPhone in Garmin Connect.

Ok so I thought I fixed the problem by updating my iPhone, but it’s not fixed. When my HRM pro is added to my device list in Garmin Connect, the heart rate monitor will not transmit any HR information to Zwift or Wahoo. Also when it’s added as a device, there’s a red exclamation point with the message “Sync Failed.” However when I remove the HRM pro as a device from Garmin Connect and "Forget this Device” in my phone settings, the HR monitor suddenly broadcast HR information to Zwift and Wahoo. Honestly I’m not sure what to do at this point.

So the only solution for this NO SIGNAL problem is buing ANT+ dongle?
3 weeks ago all was working fine, after update to windows 11, the HRM PRO strap does not show HR, even it is connetced in device pairing menu. Please check out this movie I have recorded.
Does Zwift know how to fix it? Don’t tel me about interference becuase I train in same place from 1 year and all was ok.
youtu.be/UkIn0uRv_Ac

So I ended up fixing this issue by disconnecting the HRM pro by removing the battery and putting it back in. Once it reset it was working properly again! :+1:t5:

THIS :point_up: :point_up: :point_up: :point_up:

Hi there!
I’ve been riding happily on Zwift on my apple tv with my wahoo hrm ( also same happened with my partner’s garmin hrm) and suddenly my hrm stopped displaying the heart rate: It connects, but displays heart rate 0, and says “no signal’”. From posts I saw an answer that I have to do a full factory reset, ( I assumed it was resetting my apple tv?) I did a full reset, but problem persists! The only thing that changed beforehand is that I added a cadence monitor ( which works like a charm), but even when I don’t connect that on the screen and go back to following cadence with the Hammer connection, it still has no hrm display. Anybody any ideas? This drives me nuts!

I’ve been running Zwift on an Apple TV for a year with no problems connecting to trainer or HRM via Bluetooth. Yesterday I finished a build of a Windows 10 PC for running Zwift with the ultra graphics profile.

The Garmin dual HRM has trouble pairing but the Tacx Neo 2T pairs easily and is stable. The connection strength for the HRM in the pairing menu sometimes shows just one little red bar, and after pairing, it reads “No Signal.”

I tried the trick of removing and flipping the HRM battery 180º, then replacing with a new battery, but the connection problem did not change in any way. I’ve confirmed all my BLE and other device drivers and OS is fully up to date on the new build.

There are a number of loose threads about HR connection issues, and the solutions seem to be:

  • Try pairing the HRM with an ANT+ dongle
  • Try a different HRM

Is there any other consensus about hardware or software settings inside or outside of Zwift that can help resolve the BLE connection problems?

2 Likes

Hi all, are there any updates on this issue? I‘m facing the same problems using a Garmin HRM pro. The signal and connection problems seems to increase from Zwift Release to Release. That is frustrating because today I finished a Race without Heart rate Data which is mandatory for getting evaluated in zwiftpower.

Thanks

I have had the same issue after my last Garmin HRM died on me. It was not working anymore with Zwift, but neither with my Garmin 830. Stuck at a steady HR. Anything I have tested, unpairing, new battery and so on failed so I requested a replacement and Garmin send a new one. But - the new device did not pair with Zwift via companion. Neither did it pair with Wahoo app, but working fine with my Garmin830 so certainly not a faulty HRM. Reset app cache, restarted phone, updated android - still nothing. Zwift Companion would detect the monitor, but not show any HR. Just 0. Wahoo would say the device is detected, but not available. Unpairing from the 830 did not help. It all seemed very strange. This phone was latest Android 11 Version, with Zwift Companion App, Wahoo Systems and Garmin Connect installed.

So I tested another phone with none of the above software and installed companion on it. Picked up the HR monitor straight away…with correct readings and not showing zero

So certainly not a Companion issue or Zwift issue, but maybe some of the apps in combination with Android 11x versions mess this up. It all worked fine till a week ago. I am sure Garmin Connect had a major update, but I have to test further to figure out if this is related. Certainly Android11+Companion should work. For most, trying to reset the whole phone to factory settings is out of question for various reasons . Hope to figure out a fix, will first just try to remove all BT/ANT related apps that are not companion, remove all cache from those apps, see if that helps.-…

It seems that despite the topic label, this issue hasn’t really been solved; or at least, after trawling through all 229 posts I didn’t see any definitive solution other than perhaps factory resets which in my book is not a solution but merely a dismally bad workaround which causes huge inconvenience. (No offence to anyone who suggested that; it’s a perfectly valid suggestion, but Zwift should be horribly embarrassed if that’s the only available workaround.)

In any case, I just wanted to share what worked for me - although I’ve only tried it once so far, earlier this evening, so it’s possible it was just a fluke. Anyway, skip to the last paragraph for the potential solution if you are short on time, but first I’ll give some context leading up to the solution.

I’m using Apple TV plus Zwift Companion on my OnePlus 9 Android phone, and after a long absence from Zwift, I came back to find that my Garmin HRM Pro exhibits either the No signal problem, or just says 0 bpm, even though it used to work great.

Restarting my phone didn’t help. Then I unpaired the HRM from my phone and it didn’t seem to help either. I also turned off my Garmin Epix watch and Edge 1040 in case they were somehow interfering, even though they shouldn’t because they talk to the HRM via ANT+ which unlike Bluetooth is not limited to a 1:1 unicast communication and therefore should allow the HRM to happily broadcast to any ANT+ device which will listen to it. But best to be safe anyway and eliminate as many possible sources of issues. By the way, before turning them off, I saw that they were both receiving HR data from the HRM flawlessly, thereby proving that this is an issue with Zwift not Garmin.

Another thing I did was check that no other nearby Bluetooth devices (laptops and desktops) were able to establish an active BT connection to the HRM which would hold it hostage and hog its BT transmission capabilities.

I’m about 80% certain that none of these experiments helped.

Finally I went to the gear setup screen and disabled the feature where bluetooth sensors are channelled through the Android Companion app, and made Zwift search again for the HRM Pro directly (still via Bluetooth). It instantly connected and started displaying correct HR data! Then I toggled the option back to connecting sensor devices via Companion, and at this point the HR data was still being received correctly. I then did a 20 minute ride and it worked flawlessly the whole time!

I have given up trying to get a HRM to work with Zwift. Initially, I used the same HRM that I used outdoors with 1040, this caused pairing problems with my garmin 1040. So I bought another HRM for sole use with Zwift, ie not sync to anything else, its a wahoo tickr and I just get ‘connected’ ‘no signal’. Im reluctant to buy another HRM as I dont believe it will work any better. Surely there is an reliable way to get heart rate details with Zwift…?

After more experimentation, I think the “solution” I reported above was a fluke - since then I’ve seen pretty strong evidence that connecting a tablet to the same 2.4GHz wireless extender which the Apple TV running Zwift is connected to will cause these dropouts. When I switch the tablet to the 5GHz router in the next room the dropouts stop. This makes sense because bluetooth also uses 2.4GHz and so is known to suffer interference from other devices in that frequency range. After ensuring that only the Apple TV and the phone running Companion are connected, it seems pretty solid.

Will the WiFi extender allow you to set the channel it uses? The answer might be there.

The extender can only do channels in the 2.4GHz range which is the main problem. I suppose I could try fiddling with channels in that range but it doesn’t seem necessary now that I’m avoiding overloading the extender with too many devices. (In particular, previously I was trying to stream Netflix etc. over it whilst Zwifting.)

Hi there, I’m new to zwift, and have this same issue, but with a caveat, in my case I use my garmin watch heart rate broadcast option, that should be like, for this purpose, kind of the same as using a chest strap.It connects via bluetooth and works with my wahoo elemnt and iPhone.

I will try the suggestions that are here, and some that I have in mind, and get back to you.

In my iPhone it works perfectly by the way, the issue is only with and iPad Pro 2020.

So, after following some suggestions I found here, and my own set of tests I can inform that, from my experience, this is an iPad OS issue, not a Zwift one.

I tried other training apps, like Wahoo System and the behavior is the same, on the other hand, with an iPhone or Android phone, the external sensors works without issue.

Hope it helps!