Error Z112 with mentions of a D:drive and Git whilst I don't have those? [April 23, 2024]

I’m new to Zwift and tried installing it today.

Used Wifi

Used Wired connection. Some suggest to use VPN or hotspot didn’t try that yet.

Also the error mentions a D: drive or GIT version control, I don’t have both on my system, so something hardcoded?

[13:11:11 2024-04-21] Downloader: Attempting to try again downloading “data\Environment\Buildings\JapanNeonCity\Textures\Ads.ztx”
[13:11:12 2024-04-21] Downloader: Created file handle for “C:\Users\Admin\AppData\Local\Temp\Zwift\Downloads\data\Environment\Buildings\JapanNeonCity\Textures\Ads.ztx”.
[13:11:12 2024-04-21] Downloader: “data\Environment\Buildings\JapanNeonCity\Textures\Ads.ztx” downloaded successfully (local checksum=-1697846607, manifest checksum=1861470645).
[13:11:12 2024-04-21]
Downloader: ERROR: “data\Environment\Buildings\JapanNeonCity\Textures\Ads.ztx” completed download successfully, but failed the file length test (manifest=20562, written=43)!

[13:11:12 2024-04-21]
Downloader: ERROR: “data\Environment\Buildings\JapanNeonCity\Textures\Ads.ztx” completed download successfully, but failed the file checksum test (manifest=1861470645, local=-1697846607)!

[13:11:12 2024-04-21]
Downloader: ERROR: “data\Environment\Buildings\JapanNeonCity\Textures\Ads.ztx” failed to download with code: 0!

[13:11:12 2024-04-21] Patcher: ERROR #Z112, FILE “D:\git\zwift-game-client\Projects\ZwiftApp\CODE\Patcher\Patcher\Patcher.cpp”, LINE 568: Failed to download needed server files for update! (Last: “data\Video\CritCityVid1.bik”)
[13:11:12 2024-04-21] Launcher: ZwiftApp.exe is not running.

This is a reference to the build environment at Zwift, not your PC.

If you search the forum for “Z112” you will find some previous comments about this error. If these suggestions don’t help, contact support.

Hi @Kevin_Vermeulen2, welcome to Forums. This is Juan from Zwift. Thanks for using this space to share your concerns.

D: file means you are having trouble downloading important files from the Zwift server. Typically, a complete uninstall (and deleting the Zwift folder in Program Files (x86)) and then reinstalling should fix this issue. Additionally, please try to follow the recommendations listed here.

In case you still cannot install, I recommend that you contact us. We will be happy to help.

Hi Juan L.,

I’ve tried everything mentioned in your link. I’m using Kaspersky Internet Security, I’ve added the Zwift executables to the exclusion list.

Then I removed the files and folders where Zwift downloads it’s data(in the temp folder), already 5 times I’ve tried it.

I also used a VPN connection when testing the installer. Any more recommendations?

This is Fernanda, part of the Zwift Suppor team. Thanks for giving a try to the steps!

There should be a default path for the Zwift files, the error displaying on your pad could be related to administration permissions on the PC, or Windows defender block for the Zwift files, in this case, as a workaround option, could you please adjust your Windows Defender Controlled Folder Access settings by making an exception for Zwift. Check out Microsoft’s article for more info.

Give that a try and if you’re still having issues, we suggest reaching out to our support team so that we can troubleshoot this further.

Workaround was to disable Kaspersky Internet Security, so it didn’t startup when pc is booted. So Windows Defender was active, next downloaded and installed Zwift, everything worked.

Also enable Kaspersky again after installation, everything works now.

Even adding Zwift to the Kaspersky antivirus list didn’t work, it had to be completely disabled. It’s a bit dissapointing of Zwift or Kaspersky that they are not compatbile with each other.

1 Like