Companion App Not Showing Workouts [February 2023] [3.43]

No its not. Stil not work on meet ups

1 Like

This is not showing up in companion when we do meet up`s and wourkout.
But when i do a workout i any route on zwift, it shows
somebody els having the same problem?

1 Like

Unfortunately it is still not working. I have updated iOS app to the latest version and still no workout on my companion app during ride.

@Mikolaj_Iwaszkiewicz

Does your Companion app go into Game mode at all? That is -when you’re Zwiftting, does the Companion app switch from the image on the left to the image on the right?
ZC_App02

If it goes into Game mode - please select any workout from any training plan. Then on the Companion app, please to go the Workout tab. If you’re not seeing your workout power / cadence target numbers - please take a screenshot. We’d like to see what you’re seeing on the Companion app.

OK @shooj :slight_smile: Thx for quick reply. I will check it today as advised and let you know about results! :slight_smile:

Well, it seems that Companion app doesn’t go into Game mode at all. See attached screens




The ride started at 2:00 PM and as you can see (last two print screens from 2:03 and 2:39 PM) Companion doesn’t care about it :wink: I don’t know if it is important but Companion was working perfectly on my iPhone 11 Pro. As soon as I changed it to iPhone 14 Pro it ignores each ride consequently. Both devices, laptop and phone are in the same wifi with no any restrictions or changes in its configuration. iPhone 11 Pro was working with laptop in this network perfectly.

1 Like

Hello,
I did a workout yesterday in a meetup and in ZC, he workout dashboard never came on. ZC did go into game mode (the regular screen). In a regular free ride the workout dashboard would come on. Thanks

Hi @Helen_Colberg

Welcome to the forum.

Yes that is a known bug, the workouts screen does not show during a workout.

Hi @Helen_Colberg welcome to Zwift forums.

Shuji at Zwift HQ here. Thanks for flagging this up. Was this Saturday session on Tempus Fugit the meetup in question?

I’ve created a ticket to try to reproduce this issue during a Meetup. We appreciate you!

Thanks @Gerrie_Delport_ODZ! Hi Shuji. Yes, it was this past Saturday meetup on Tempus Fugit. Thank you so much! :smile:

Hi @shooj

It does work correctly on I-phones it is only Android devices that does not show the workout screen during meetups.

I have the exact issue with my iPhone 14 pro. When I upgraded the game screen just doesnt work anymore. All my other devices like iPad and iPhone XR works just fine.

I say BS, problem still exists after update and reboots. I did receive this reply from support today however:

“* Hello Tim,

This is Rowdy at Zwift HQ. We have discovered that the cause of this issue is related to a change in the main Zwift app. I have updated our developer ticket and will let you know when we have more information regarding a fix. Please let me know if you notice this experience in any non-meetup workouts.

Ride On.
Rowdy B.
Zwift Community Support*”

1 Like

@Gerrie_Delport_ODZ I am on an Iphone. My husband (also Iphone) has the same issue. We have not been able to do meet ups and have workout screen show on ZC. All game and ZC version up to date.

1 Like

I am having exactly the same issue and have for ages now – weeks. I mainly do group meet up workouts and the workout screen not showing at all - second tab on ZCA is just DASHBOARD. Particularly annoying as means I can’t toggle ERG on or off from ZCA – and I can’t access my lap top during a workout.

If anyone knows how to toggle ERG ON OR OFF from ZCA I’d be grateful as the rest I can cope without but I need this function for sprint efforts

Thanks in advance

Same issue here, since 1.33 for weeks now. Zwift running on Windows10 machine, ZCA on iPhone, all software up to date.

ZCA connects normally to a running Zwift session using workout mode, but will occasionally not switch to “workout” tab, instead staying in the standard “dashboard” tab. ZCAs behaviour is not determined, sometimes it works, sometimes not.

Additional comment/observation:
False “dashboard” tab switches to “workout” tab directly after finishing a meetup → ZCA is buggy when running a workout in a meetup…

I have updated to version 3.46.0 (1457). Last few rides I select a Workout and then a Route and start my ride. But my ZC goes into game mode and the pervious option to go into Workout is now longer there - and important to me is that I can no longer change intensity. Am I missing something that I need to click? Or as seems from these posts there is an software issue so the Workout screen is no longer available?

Is this issue ever resolved? For me the workout screen doesn’t even appear and sometimes if I restart multiple times it comes randomly and middle of the workout it goes away again. Really frustrating. The only thing I care about is the speed dial graphic, as it’s a good way to visualise the power and keeping in range. Is there away to get this on the main zwift program whilst working out?

I don’t think so. On Android, lately I’ve often had the App just freeze after 10 minutes, and unfreeze 10 minutes later. If I’m in a workout it just looks as though I’m stuck on a particular rep and the buttons (“erg mode”, Workout intensity etc.) stop working, and on a ride the map doesn’t update my position and the rideon feature stops working. I can always tell it’s happened without looking at my phone because my laptop stops making game sounds while the App is frozen.

The issue is still there. Any updates on a solution?

Check this post:

And this one: