Apple TV dropping trainer connection when using Siri remote [August 2023]

Since 1.46 update on Apple TV Zwift immediately drops trainer Bluetooth connection when the Siri Remote voice command is used (e.g. to choose a new podcast) during a ride. Same occurs when using menu to bring Podcasts to the front to change track manually then return to Zwift. Have to re-pair before the ride can continue. This worked fine previous to the latest 1.46 update.

1 Like

I have the same issue, cant come out of the app without connection dropping so cant use pip with apple tv+

I noticed the same issue yesterday. Hit button by mistake and dropped all BY sensors

I listen to Apple Music while riding and use the Siri button on the side of the remote to skip songs or change stations.

The last time or two I’ve rode when I use the Siri button the app stops being able to update them into from my devices - trainer, hr monitor, cadence. I have to end the ride and start over.

I’ve also had situations when doing a workout it doesn’t switch erg values. For example the training is supposed to drop to a recover level but it doesn’t. The app is saying less power but the trainer isn’t greeting easier - it’s starting at the harder power level. Unfortunately I can’t remember if I was using the Siri button at the time it happened though.

A friend has this issue too.

I have experienced the same problem,is it being investigated?

I also have this issue.Tried the delete app and install route,made no difference.
4K Apple TV SET UP.Using Siri whilst riding unpairs devices,

Discovered this while testing the current TVOS 17 public betas and Zwift. Having paired connections via bluetooth on AppleTV (Kickr v5, cadence from Kickr and Wahoo tickr). When you press the Siri button on the Siri Remote, all connections are dropped and stop working. Need to go back into the pairing section on the menu to get them working again

So not sure if its an Apple issue with TVOS OR a specific Zwift issue with the current version of Zwift, but given the soon to be released nature of TVOS 17, thought raise here also

This has been posted about before when pressing the Siri button, so I don’t think it’s related to tvOS 17.

1 Like

Only occurred for me with TVOS 17. Always worked correctly with TVOS 16.x

I started this topic

with the same issue, but only noticed on TVOS 17

Looks like this issue was also reported over here

Perhaps @Gerrie_Delport_ODZ or @Daren could merge the threads together, please?

@shooj Is this issue being looked at? Seems Zwift has triggered this issue in recent update?

Yep, experienced the same thing
Accidently hit the back button (exit app button or whatever it is) so Zwift closed…still running in background of course, jumped straight back into the app and lost all bluetooth connections
When stopped, jumped into settings, re-paired and off i went again

This never used to happen

Done and Done


@shooj @Rowdy This should be moved to known issues? ETA for fix

I’ve flagged this up at HQ for further investigation. No fix ETA just yet.

1 Like

Yep- same issue here. Very frustrating too when I’m into a long training program and my use of the Siri remote (to start or skip music tracks) kills my entire session. Please issue a fix soon! Used to work just fine.

I’ve had same problem,using Apple 4ktv,all new updates installed.