Zwift on Android phone

Hello there! I’m trying to start zwift on my oppo a54s but it doesn’t work. The blue screen opens and after a while it disappears again. I’ve tried many things, restart, deinstall and reinstall, I’ve checked the memory available, the ram size, the antivirus etc… Can anyone help?

Has it ever worked it is this the first time you’ve tried?

It worked some time ago. But I cannot remember if it was on this phone or the previous one.

Thank you for getting back! I appreciate your help!

As a general rule of it installs then it works.

However if all the phone brands that i see the most trouble with its Oppo. Seem to get some strange issues.

Samsung has a fair few but that’s proportionate to their market share and it’s generally their new to the market phones that cause issue such as the Folds because of their technology.

1 Like

Ok. But is there anything I can do?
I don’t want to buy another phone…

The only thing i can think to eliminate that it’s a glitch with your phone is to do a factory reset of it then try it prior to installing anything else on your phone.

It could be clashing with something else you’ve installed or it may be a lack of available memory/storage.

I have 44gb of free space and 8gb ram, should be ok…

Some setting you changed or a software glitch on the device could potentially trigger a crash. If you’re determined to use the phone, a factory reset is one of the things to try when you can’t figure it out. You could also contact Zwift support and see if they can debug it from a log file.

Thanks Paul.
I’ll see what I can do before resetting the device.