Trainer Calibration


(Cleve Waterman 69y/o) #1

 Can you give us more info on the new “trainer calibration” feature?  As I understand it, a button will appear on the pairing screen after a few starts of Zwift.  Which trainers are supported (specifically, is the Wahoo Snap supported)?

Thanks!


(Jon Mayfield) #2

Indeed a calibration button should show after a few startups if you pair a trainer as “FE-C” when using ANT+.  

It should look like this:

 

If you are on a mac or iOS and you pair to your Wahoo trainer over bluetooth then it will also show.


(Shaun Elphick V52) #3

I met this for the first time today, Zwift would  register any power until I had completed a spin down, then all was fine.  Seems like a good idea from the Zwift team to help keep the KickR calibrated regularly.


(Cleve Waterman 69y/o) #4

I have used Zwift on my PC several times with my Wahoo Snap paired as FE-C but I have not see the calibration option.  If I use Zwift app on my iPhone, the wrench icon for calibration does appear on the iPhone screen.   Am I supposed to have the calibration option on my PC?


(Michael D [BRT]) #5

This doesn’t work for me. I start the spin-up but the speedometer stays at zero. I’ve tried over ant+ and bluetooth - using a Kickr on the PC version of zwift.


(Jason K) #6

@Mike: does the spindown work in the Wahoo Fitness app? If not; it may be a hardware issue - if it works there, but not Zwift, open a support ticket so we can troubleshoot with you.


(Michael D [BRT]) #7

Yeah works fine in the Wahoo app, just not in Zwift unless I’m doing something wrong. I’ll open a ticket cheers.


(Paul Wolf) #8

Having the same issue as Mike D where it works fine in the Wahoo app but not in Zwift. What was the resolution since it should apply to everyone who is having the same issue.


(Michael D [BRT]) #9

The problem has been resolved for me since the latest update to Zwift. I’ve not tried over ANT+ but it works fine when the trainer is connected via Bluetooth/Zwift mobile app.


(J LeBel) #10

I’m having issues with this in-game calibration. I’ve tried to do it a few times, with different computers, but always get a Timeout. It will ask me to spin till I reach 37Kmph, which I do, and then I let it spin down. It takes a while for it to finally hit 0Kmph, which then I am presented with a “Timeout”.

I’m using a Tacx Vortex Smart, and I did calibrate it through their app first (although, there’s something weird with that as well).


(Cleve Waterman 69y/o) #11

The in-game calibration appears to be working well with my Wahoo Snap (1st gen). A few suggestions. I would like to see the spin down time reported, just like the Wahoo app. It would be better if there were some kind of countdown timer while I am warming up the trainer prior to the spin-down. Finally, have some immersive graphics on screen while I am warming up the machine. Even a virtual trainer would be fine, like the trainer we use while waiting for a group ride. The Wahoo app will tell me to do an advanced spin down every couple of months. I don’t know how it decides to do this.


(Derek Rush [RaceWBR]) #12

I recently got a new Magnus trainer. I did my initial calibration through the Cycleops Rouvy app and everything worked great. Yesterday I decide to do another calibration using Zwift and now everything is a mess. After the Zwift calibration I was immediately propelled along the course at 2000w. I was forced to unpair the trainer and went back to Rouvy to do another calibration. Now, even with the Cycleops spindown, my trainer resistance feels fifty or more watts higher than what the power numbers are showing on the screen. Multiple calibration spindowns have yet to remedy this situation. I should have left well enough alone. Thanks Zwift for killing my new trainer.


(Cleve Waterman 69y/o) #13

Derek: Have you tried uninstalling Zwift from your computer and then re-installing it?


(Richie Close (RACEWBR) A) #14

Hi there.  I setup my wahoo kickr (Gen 1 with strain gauge disabled).  I launched zwift and paired it as FE-C over ant successfully.  However, I don’t see the calibrate icon.  Is there anything I’m missing?

Thanks

 

Richie


(Richie Close (RACEWBR) A) #15

Found this post today.  https://support.zwift.com/hc/en-us/articles/115004175663-How-to-calibrate-your-trainer?mobile_site=true so is it safe to say my kickr can’t be calibrated within Zwift?  Is there a reason for this?  I can perform a calibration in other training app’s.  Or is there a workaround?


(Michael D [BRT]) #16

Well that says it can’t be performed under bridged Bluetooth connections (Zwift Mobile Link app) but it works fine for me that way, so you could try that method.


(Richie Close (RACEWBR) A) #17

@Mike D - how do you do that?  I paired the kickr over bluetooth fro the Mobile link app, but can’t see a calibrate option.


(Michael D [BRT]) #18

I just ride for 5-10 mins then go to the pairing screen (press ‘A’) and should be the spanner icon


(Richie Close (RACEWBR) A) #19

Problem solved! The issue was I did not have the ‘controllable trainer’ set to FE-C!


(Robert Hammerschmidt) #20

I have a Magnus Smart trainer with an ANT+ dongle.  I run Zwift on a Windows 7 PC.  I do not see the “Tool” option at the pairing screen.  Thus, I am unable calibrate my trainer.  I would really like to make sure that my Watts are accurate.  Otherwise, LOVE Zwift and so far the support is excellent!