Play Controller frozen

Left controller is powered on and frozen. I cant turn it off. Companion app doesn’t see it and it will not connect to zwift. Latest firmware was applied. Also use ATV,

Does it not turn off if you hold the Z button down for 10 seconds?

I think if you hold it down for 30 seconds it will reset.

I tried it. It does not.

Sounds like it’s developed a fault. I guess the battery will go flat soon.

One thing to try us to plug them in to charge. It might cause them to enter a different state that then allows them to turn off.

I plugged the charger in and charged both controllers. Left still didnt turn off.

It looks like a fault then. Does the companion app as it in the firmware update section?

I updated firmware about 2 weeks ago. The companion app sees the right controller but not the left.

I’m just intrigued if it’s seen on the firmware updating page.

Just got a notification in the Companion app of a firmware update.

Battery life must be good, it’s been on all week

I had the same problem with my left controller. I held in the power/start button for a minute and then it turn off. It now refuses to turn back on again. Even if I plug in the charger, it stays off.

I let the battery run out. I then charged both controllers. Yesterday , I applied new firmware and it seems to be working.

Tried to update the firmware on mine. LEDs both turned to yellow. Firmware update failed with an OOPS message on ZC app. Then neither controller could be updated, used or even turned off. After 24hrs on yellow, Zwift advised me to shut them down by holding the Z butttons for over 30 seconds. This worked and the yellow lights went out. However they are now totally dead and cannot be turned back on, I’ve tried re-charging them but to no avail. Only used once! Not a great experience so far. Awaiting further technical assistance… While they were on Yellow ZC App could only see the Right controller.

Same! on both…

Anyone know what is in the firmware update?

this just happened to me yesterday. i have tried to reset, hold for 30 seconds, etc. nothing. tried recharging, etc. same response. just a big persistent Z. doesn’t blink.

so, it sounds like if i let the battery run out that will maybe allow me to reset? any suggestions, otherwise.


Just let battery run out. Recharge and you should be good. This happened to me.


Thanks Vince. So strange that it does this though. and that a hard reset isn’t possible.

~Sean Fitzgerald
(404) 933-8527

I had the same happen to me, stuck red and couldn’t turn off, I just held the Z button and after 1 min (timed it, had tried 10 and 30 seconds several times so just helf it down when watching a youtube video) it turned off and has been ok since