I am at my wits end

I have tried Zwift on my iPad and therefore got it to connect to my Tacx Vortex Smart. Picks up the trainer but the cyclist never moves and no speed reading. I therefore decided to load it on my laptop and buy an ant+ dongle. Again loads fine, picks up the trainer but no movement or speed/ cadence. Interestingly my Wahoo HRM does read. About to unsubscribe as frying my brain. 

1 Like

Hey John, that sounds frustrating.  What you describe makes me suspect the power calculations inside the Vortex are the issue.  

To be clear, are you seeing 0 watts in the top left corner or do you see a changing number when you pedal in Zwift?  We don’t read the speed from the trainer, just watts, so that is the number we need to investigate.

Can you try downloading the “Wahoo Fitness” app on your iPad and see if it ever sees non-zero watts when you pair the Tacx Vortex as a power source?

I am having the same problem. Using Alienware i3, and elite direto trainer. When pairing doesn’t show the elite direto trainer, however shows elite 700.  Try to ride and no movement. Very frustrating!!! Any help would be appreciated…

How are you pairing it?

Can you post a pic of your pairing screen.

The more info you give us the faster we can help in resolving your issue.

Hi Paul,

While I was taking photo of my pairings to send you I noticed that the Power Source and the trainer were different. I reset them to the same and it now Work’s perfectly. Thank you much for your help.  

Jon - sorry wide of the mark again. As an aside the wahoo app works perfectly when I use it with a speed and cadence sensor and to be clear when I try and use Zwift the rider simply will not set off so clearly there is no speed or wattage. 

I did wonder if the wahoo sensor was interfering with it on Bluetooth but using ant+ still doesn’t solve the issue. The really annoying thing is I did get it to work briefly at the start using Bluetooth but never since. 

I’m running into a similar issue. My set up is wahoo kickr with my iPad. It worked without issue for about two week. Last week got on to ride and went to perform spin down it goes to 2 mph and just stays there. Then if I cancel go in to ride, trainer is paired via Bluetooth but avatar moves about 10 ft after 25 sec avatar stops even though I’m riding and I get no speed or watts. I also have a Pioneer power meter on my bike. I’ve read all the troubleshooting and I get avatar not moving because packets aren’t getting thru to app. It’s been almost a week and I’ve tried everything firmware is upgraded, deleted and reinstalled Zwift on iPad and it’s driving me crazy that I can’t get it to work. When it’s been working fine and suddenly doesn’t. Very very frustrating.


thanks in for any ideas…


Marc,  I’m not aware of any current issues with a kickr on iPad - it’s a very common configuration so I’d like to see if there’s something specific to your unit.  Can you grab the wahoo fitness app on the iPad and see if it reads power properly?  If it does, close out that app and immediately see if it works in Zwift.  Should be a good test to verify the iPad can hear properly from the KICKR.

I will try that Jon and get right back to you


I connect wahoo utility with no problem. Try to do a spin down for about 2 sec it shows 2 mph then back to zero and never shows any watts


You might want to contact Wahoo support on the issue: https://support.wahoofitness.com/hc/en-us

Thanks Paul I will try that too.

Hi Jon, this is screen shots of connection with trainer. I get a momentary 2-4 mph then nothing at all while continuing to ride at brisk pace.