ZwiftGame Android FAQ (v.1.0.50775)

Hi There,

Found this thread by following the various Android & Ant+ threads.
If this is not the right place to post, please let me know where I can repost this question.

I have a Huawei MediaPad T5 that has EMUI 8.0 (a variant of Android 8.0)
I have all ANT Radio Service, ANT USB Service and ANT+ Plugins Service all installed. I also have the ANT Tester app installed.
I also have Zwift v57540-1.0.57540 installed on this tablet.

I also have the ANT+ Plugin Sampler, and using this, I can confirm that the the OTG cable and Dongle are both working and that I can receive telemetry from both my Kinetic InRide 3 and Garmin Cadence Sensor (Model: F4ECNA01).

However, when I open up Zwift, and attempt to locate these devices to pair them using ANT+, the pairing screen just sits there, seemingly stalled saying “Searching…”

So this can’t possibly be a hardware issue, since I get telemetry from ANT+ via the Plugin Sampler, and I’m at a loss as to why Zwift can’t locate these (or any) ANT devices on this tablet.

Please help!

Hi Paul,
Sounds like you have all the right components installed. The fact that it works with the Plugin Sampler is encouraging.

That said, it could be a permissions issue. Take a look at this post and see if it helps.

Thanks for feedback, and including all those details.
Will

Hi Will. Thanks for the quick response.
I’ve reviewed the post you linked, and and tried to follow it.

Most of the issues presented in those are for built-in hardware ANT not working. I"m using a dongle. As such the permission to “use hardware” doesn’t show up.

as a result … I’m still stuck.

Paul,
Here is my ANT Tester screenshot from a Google Pixel 4a, w/ dongle attached.

So you can compare. Note my versions are from the play store, not github, on this particular device.

Will

Hello Benno,
Welcome to the forums. The Tab S6 is a great device for Zwifting.
The S7 has an even better GPU though I haven’t used it myself.

What’s great about these tablets is you can hook up HDMI directly via a USB C to HDMI connection and output directly to TV.
It’s not 4K or anything, but it looks very nice!
Ride On,
Will

Question about Zwift on Android. I am using a Samsung Galaxy S5e tablet to run Zwift. Just resumed using Zwift for the fall/winter. I have seen Zwift update twice this week. Here’s my issue: if I take pictures during a ride, when I complete my ride Zwift displays the pictures as being uploaded to Strava, but the pictures are not being uploaded. So I thought hey I’ll just find the pictures and upload them to Strava myself. But I cannot locate the pictures on my device. Last winter all the pictures were dropped into my photo gallery, but none of the pictures taken in rides this past week are showing up anywhere on the device. I have even done a file search for all jpeg files and not found them. So I’m seeking some help on this. Thank you!

Hi…

I have now ordered a gaming notebook with a GeForce GTX 1660 qmax graphics card and an I7 processor.

I hope ZWIFT will work on that !?

The Android version is too insecure for me and I would like 4k on my 50 "TV

It’ll be fine, but you’ve spent a lot more money than you needed to, especially considering you’re not going to be using the screen.

1 Like

Hi Will.

Here’s a screenshot (single composite image) from both my Pixel3 (which works in both ANT+ Plugin Sampler and in ZWIFT), and the my Huawei MediaPad T5, which doens’t work in Zwift at all (but does in the Plugin Sampler)

Apart from a plugin version difference (that I actually can’t explain since both were downloaded at the same time), I don’t understand why Zwift can’t seeing ANT devices, when the Plugin Sampler does.

(I can’t upload media or post links for some reason, so I’m providing the link to dropbox but broken up in pieces … sorry you’ll have to reassemble the link)

www . dropbox . com /s/d2qpkp0fjjnlp28/ANT.png?dl=0

1 Like

Oh, I will use my big screen, because of that I bought an Notebook with 4K graphics…

I meant the screen on the laptop. :wink:

So is this update the cause of nerfing the ANT signal when I use the Companion app?

I can pair my laptop no problem using an ANT dongle and extension lead - as I always have done since the end of 2014 - but recently whenever I launch ZC I’ve been getting a “No Signal” dialogue on the pairing screen or it’s really glitchy and keeps switching on and off - which impacts racing and group events when I’m left on the start line moving nowhere. I can’t stop using a dongle until Android FE-C support arrives otherwise I will lose the controllable trainer.

As soon as I disconnect Companion everything works normally, no glitches, no dropouts. Perfect.

I’ve eliminated (or minimised) ANT and 2.4Ghz Wifi conflict by changing router channel settings and my Samsung S8 is connected via 5G. But no solution yet…

Oh yes,sorry :wink:

But do not need the notebook only for ZWIFT !

I bought it especially to work with it, and not to play with it :wink:

1 Like

The latest update this weekend seems to have made my connection through bluetooth or Ant+ stop working on my Tab S7+. I have had a delay in connecting before but never has it not connected at all. I tried to restart a couple times. My Ant+ was already enabled automatically before so I do not know if the new update took the connection off completely. I can still connect with my Samsung S10+ phone but this was a test and not my primary device for zwift.

I am struggling to set up my zwift. Huawei mediapad m5 lite, unbranded ant+ dongle (which works on a laptop), belkin Usb-c to usb. On ant+ tester I get this?
It’s a tacx flow t2240, garmin dual HR and assioma duo pedals (all work with the ant+ on a laptop, which the gf uses now when I’m on zwift).

Paul,
Thank you so much for the screenshot. I’ve logged a bug for this. No ETA yet, but we are investigating.
In meantime, I suggest you contact our support team, and log a proper support ticket if you haven’t already, so they can track the issue.

This might be an issue specific to Huawei devices, so if others have feedback on Huawei / ANT+, please share.
Thank you,
Will

I just bought a brand new Samsung Galaxy Tab S5e. Zwift runs smoothly on it.
And I have a Tacx Neo 2T.
And have trouble with ANT+ (Bluetooth works perfectly, but I need ANT+)

S5e comes with Android 9.

  1. with factory apps and setup, not possible to connect with ANT+ to my trainer
  2. ANT+ service update: now ANT+ is fine: I can see power and cadence on Zwift (no FE-C but this is expected)
  3. update to Android 10 + latest ANT+ plugins/services: my Neo is now invisible ! But my ANT+ HR belt is seen properly and is (sometimes) strangely displayed as “Garmin” while it is not a Garmin belt.
    Tested with some ANT+ test app: I can see power value via ANT+. But no Neo in Zwift’s device list…

Any other similar feedback from people with Galaxy Tab Sx running Android 10 and integrated ANT+ ?

Hello Alain,
Welcome to the forums.
Thanks for the report, and asking for feedback on these very popular and awesome Galaxy Tab Sx devices! They are great for Zwift.
Our lab and trainer testing has been impacted during this lockdown, so we appreciate your patience.
We will do our best to investigate next week.
Thank you,
Will

Alain, I am also running Zwift on a Galaxy Tab S5e. I only use BLE for connection. When I pair my devices, I see a list that populates as the tablet detects the items both over ANT and BLE. I always select the BLE option to pair my tablet to my trainer (also a Tacx) and my Garmin cadence sensor & HR strap.

I tried yesterday a workout with Rouvy app via ANT+ (with Bluetooth turned off to be sure) and it works fine.

You can find below details about my devices:
Tablet:
Samsung S5e SM-T720
Android 10
According to “ANT Tester” app:
Built-in ANT detected: Yes
USB On-The-Go support: Yes
ANT USB Service installed: No
Built-in firmware: AVN1.01B07-MCI
ANT HAL service: 4.0.1
ANT Radio Service: 4.16.00
ANT USB Service: N/A
ANT+ Plugins: 3.8.10

Zwift app version:
v57791 - 1.0.157791, french

Trainer:
Tacx Neo 2T
Firmware 1.1.56