ZwiftApp cant connect to api

Hi everyone,

Somehow Zwift connection has stopped working for me. It has worked before, but I have no idea what the steps are why it isn’t working any longer.

NETCLIENT:[ERROR] Curl error: [56] 'Failure when receiving data from the peer' for: GET https://us-or-rly101.zwift.com/api/telemetry/config

I can access this url in my browser

I can logout and login in the ZwiftLauncher

I cannot login in the ZwiftApp

Any ideas?

kind regards,
Gilbert

Have you checked your firewall settings? I’m wondering if it may be that you need to whitelist Zwift in your firewall.

i have added zwiftapp to allowed app, nothing changed. Any other ideas?

Hi Lauren,

I have no problem in Command Promt:

curl https://us-or-rly101.zwift.com/api/telemetry/config

Response

{"url":"https://api.segment.io/v1/track","key":"aXBSdlpza3p1aVlNOENrMTBQSzZEZ004Z2pwRm8zZUE6","sampleInterval":60,"urlBatch":"https://us-or-rly101.zwift.com/hvc-ingestion-service/batch","batchInterval":120,"remoteLogLevel":3,"innermostCullingRadius":1500,"endpointUsage":false,"analyticsEvents":false,"isEnabled":true}

Also the launcher works fine, I can login and such. Just the app has problems

That’s odd. I know this might feel redundant, but have you tried doing a clean reinstall of Zwift on your computer? There’s a useful guide for that here.

Also, I was wondering where you got the error that you included in your first post. As far as I know, NETCLIENT & curl errors are found solely in launcher logs, so if the issue is only with the Zwift app itself I’m unsure why you’d be getting an error there. Unless perhaps what you mean is that you’re getting an error and are unable to launch the game entirely?

Hi Lauren, thanks for your suggestion.

I followed the guide, reinstalled, installed, updated. Then started the Launcher, logged in, then launched the game. The game launches and shows another login screen. Same error still occurs in Documents > Zwift > Log > Log.txt , so from ZwiftApp login.

Can you check again, because it seems NETCLIENT & curl errors do occur in ZwiftApp. Thanks :)!