Zwift won’t upload to Garmin Connect


(Matthew) #41

I’m having the same issue. I just started using Zwift this week. My rides sync with Strava, but not GC. I attempted to import the .fit file into GC and received “An error occurred with your upload. Please try again.” I took a look at the Fit File Repair Tool linked in this thread, but the download was detected as a containing a virus in Windows 10.


(Vincent) #42

Hey all, we’re monitoring recent cases of this. We’re investigating for ways this function can be improved. Thank you all for your feedback!


(Fazlee) #43

Yup, just did a 30 km workout plan today and it didn’t sync to Garmin. Synced to Strava, TP, just fine, though.

.fit file not able to be uploaded to GC. Results in unknown error.


(Christian Jensen [DBR]) #44

I have had the same issue the last couple of days.
It connects with Strava just fine.
Nothing is happening on Garmin connect.
When I download .gpx from Strava it makes the different elevation and doesn’t know sport or name of the Strava/Zwift session.
Can someone help me?
I have tried to disconnect it all and reconnect. :frowning:


(Derek) #45

Here are a couple FIT files that failed to upload to Garmin Connect for me but worked elsewhere, if that helps in your debugging process –


(Derek) #46

Also, here is another thread in the forums for the same issue – Zwift .fit files not loading to Garmin connect


(Tania) #47

Same issues here - cannot upload to Garmin Connect. Works across other platforms…


(KK) #48

Same issue
Yesterday ride failed to upload to Garmin Connect
Today ride successfully auto uploaded but with delay


(.) #49

I’m having the same issue but only on longer rides. It seems anything in the 1-30 mile range syncs fine to all platforms (garmin, strava), but longer than that and there is an issue with the file that prevents syncing with garmin connect. I tried manually uploading the file and I just get an error message. I am running the latest version of Zwift on an iMac running OS 10.14.2.


(James) #50

So here’s an interesting one…

I rode this morning, 35km. File automatically uploaded to Strava, but not to GC… manual upload to GC was a failure.

I found the .fit file on my computer and ran it through the https://www.fitfiletools.com “Corrupt Time Fixer”, without selecting “normalise time”. Downloaded the new file and uploaded manually to GC and it worked. Correct time, elevation and power data etc as was synced to Strava


(Stefan) #51

Same problem here for the last week now. upload to GC worked fine for the last couple of months but suddenly stopped. on Sunday Feb 10th. The day before everything still was ok.


(Vincent) #52

Hey all, this is an issue we’ve been aware of and are currently investigating. I’ve created a Known Issues thread here: Zwift rides/runs not saving to Garmin

Please reply to that thread if there are any additional pieces of info that seem unique to this case. Thank you!


(Vincent) closed #53