Zwift won’t upload to Garmin Connect


(jason) #21

Hello All.
I have my accounts/apps synced between garmin connect, zwift, strava and stryd.
My zwift rides upload automatically to strava and garmin connect no problem at all.
However when I run on zwift, only strava uploads and not garmin connect. Any ideas please?
Jason


(Peter Slump) #22

I’ve got the same issue. If I connect my Garmin-account again to Zwift (e.g. by connecting it through the Companionapp) the upload works again for a few days. But after a fey days the upload to Garmin will be lost again, while uploading to Strava works fine.

@Vincent_Williams1 It seems like a lot of users are having the same issue. Is there a solution?


(Edgar) #23

After doing this, have you had any more issues?


(..Troy) #24

I’ve tried the disconnect and reconnect today and it didn’t work for me


(Thierry) #25

Hi I have the same issue after disconnecting to Garmin connect and strava and reconnecting now with Garmin connect / strava and trainingpeaks
i have tried a very small workout and it s not syncing with them.


(Vincent) #26

Sorry for the delayed response @Peter_Slump I’m looking into this on our side!


(Kent) #27

I also am having this problem, but only with some of my rides. Today it uploaded. Yesterday it didn’t. I am also connected with Strava and both yesterday’s and today’s rides are uploaded on Strava.


(Peter Slump) #28

I’ve got an update on the issue. Yesterdayevening I rode 2 separate rides: a warming up, followed by a group ride. The warming up was synchronized to Garmin Connect, while the group ride didn’t become visible on Garmin. Strange eh? Maybe this helps narrow it down a bit.


(Darryl Rosenfeld) #29

This has not been a recurring problem for me since shortly after posting. Maybe one other time, I’ve had to manually upload the file to Garmin, but I ride on Zwift 5-6 times a week and since that time that I posted, really have no concerns. If it happens every once in a while, I can manage, just don’t want it to start happening very often. Good luck, Kent.


(Thierry) #30

There are a few reasons we’re aware of that could prevent your ride from saving and your .fit file from uploading:

  • If a ride is less than 2 km, it won’t upload to Zwift or third-party sites: this was designed to prevent short test rides from clogging up activity feeds, while longer rides (over 2 km) should record normally.
  • You’re out of storage space on your device: if this is the case, try clearing up some space by removing unused programs or files.
  • (PC/Mac) You’re using a school or work computer: switch to a personal one instead and make sure you’re running Zwift as an administrator. We only support standard setups at this time.
  • (PC/Mac) There’s a sync program (like Dropbox or One Drive) syncing your Documents\Zwift folder: We recommend either excluding your Documents\Zwift folder from your sync program or temporarily closing them while Zwift is running to prevent conflicts.

Try making those changes, and let me know how it goes!


(Thierry) #31

That’s the answer I received from the support
My issue was due to the first reason


(Marc) #32

I am in touch with the Support about this issue as well. I noticed that everytime it does not upload, you find a file “activity in progress” in the activity folder. (running a Win 10 machine) Maybe it has something to do with this that Zwift is not shutting down properly.


(Marc) #33

It did upload today although I also had the file “activity in progress”. So I believe it can’t have to do with this…


(Gary Johnston ) #34

Also having the same issue where ‘some’ of my rides aren’t uploading to GC. They upload to Strava ok…started doing this about 2 weeks ago. Have disconnected GC from Zwift and reconnected…but still getting about 50% of rides not uploading. Also when trying to import the .fit file manually I get errors on GC’s website.
Using Apple TV.


(Johannes) #35

Im facing the same problem. Some rides will sync to GC, some not. Nonetheless all rides are on Trainingpeaks and Strava.
I haven’t tried reconnecting so far (will do that right now).
What I recognized:
You won’t be able to upload the .fit File either from your computer (documents/zwift) nor if you download the .fit file from my.zwift.com or Strava.
But there is a workaround: You can go to Strava and type export_tcx after the URL of your activity. GC will accept the .tcx file.
You still have to change type of activity in GC. It’s a little tricky, but you can do it. Click on the activity and you will find a drop down menu on the upper left corner where you can select virtual ride.
All tested on Windows.

Hope there’s a fix soon.


(Paul) #36

Same issues here - interesting this is only affecting sync’ing from my Mac, if I use my iPad Garmin Connect sync’s fine! The other issue is ride completed on the app are also not sync’ing to MyZwift! Like everyone else here this has been going for for some time (my last auto-sync’d ride to MyZwift and Garmin is 16/01).

Come on Zwift!


(Marc) #37

I tried several things but couldn’t find a pattern when it uploads and when not. Yesterday it did, today it didn’t again. According to Zwift support this has to do with ping times being higher than 50ms. Living in Switzerland, there is no chance to get 50ms of ping to LA servers. The strange thing is that my setup has not changed since 2017 and also the ping times have always been around 180ms. In the past the uploading to Garmin Connect has worked fine. So I believe it must be some kind of bug either on the Zwift or Garmin side.


(Derek) #38

For anyone curious, there are a number of us with this issue and this thread in the Garmin forums has some nice users willing to fix your FIT file for garmin connect when it fails. Maybe someone from zwift can reach out to garmin to figure out why some FIT files are failing to upload to GC but are working elsewhere (Strava and Training Peaks in my case)


(John Brooks) #39

I’m having same issue. Only weighing in so that Zwift has visibility to how many people have this issue. Works fine for Strava. Garmin Connect, get nothing.


(michele) #40

New to Zwift and also having issues with rides not connecting to GC. Strava is fine.

Hoping Zwift has a solution soon!