Zwift won’t upload to Garmin Connect


(Kyle Duffy) #1

I have had no issues the last two months with the automatic upload from zwift to Garmin Connect after my rides.

I updated the Garmin Connect app a few days ago and my ride that day and today did not upload.

Has anybody had any issues the last few days with zwift to Garmin Connect too?

I also have Strava sync’d and it has uploaded to there fine on its own…

I tried manually uploading the fit file and it gives an error.

I know it isn’t a network issue or anything related to my pc. It has been flawless up until two days ago.


(Kyle Duffy) #2

Both the rides that have not uploaded to garmin connect were the Zwift Academy semi-final workouts #1 and #2

Has anybody else done those and had them not upload to garmin connect?


(Maarten Geijsberts) #3

Do not no what happend here, but all of my rides were uploaded to Garmin Connect. Must say I haven’t had a update for the app for some weeks now. Maby the recent update is causing the problem?


(Vincent) #4

Hey @Kyle_Duffy , are you still having trouble updating to Garmin Connect? Have you contacted their support?


(Andrew Sanders) #5

I am having the same issue. My Zwift rides upload to Strava with no issue, but will not upload to Garmin. When I download the .fit file from zwift and try to import it manually I get this error: “An error occurred with your upload. Please try again.”


(Darryl Rosenfeld) #6

This started happening to me on Monday of this wee, including the error message while manually uploading the .fit file to Garmin. Then Tuesday the automatic sync occurred perfectly. But yesterday (Wednesday) didn’t auto sync, but I WAS able to manually upload the .fit file to Garmin. Weird. If it’s persistently problematic, I’ll contact Garmin’s support (ugh).


(Jacob Asay) #7

I am having the same issue as everyone else. I have done two rides and neither has made it to Garmin. Everything is making it to my Strava account just fine.


(Michael Sternberg (ZRG)) #8

Same issue since this week too, no upload to Garmin connect when i end the ride manual. If I change from a ride into an Event, the automatic upload to Garmin is working fine.


(Jan Van T Hoog) #9

Any solution for this “problem”


(Simo Rockabilly) #10

I had the same issue today but fortunately I find something good online:

Uploading your Zwift rides to Garmin Connect

  1. Log into Garmin Connect via your web browser.
  2. Go to your Activities page (Menu>Activities)
  3. Click “ Import ” in the upper-right hand corner.
  4. Click “Choose File” and find your ride’s .fit file (they are in the Document/ Zwift /Activities)
  5. Click on the “ Upload activities from file” to finish.

Have a nice ride!


(John Brooks) #11

Having same issue. Zwift ride not uploading to garmin connect. Has there been any sort of identified bug here? Is there a setting that needs to be checked? Rather not do this manually. Anybody figure this out yet? Thanks!


(JF) #12

I’m in the same boat. Nothing is getting uploaded to Garmin Connect, but rides and runs are getting to Strava and TrainingPeaks.

In Zwift settings, I disconnected Garmin Connect and reconnected. Hopefully the next activity will get there.


(Dana Ostrenga) #13

I am having this problem today. My Zwift run uploaded to Garmin but not my ride. When I tried to manually upload the *.fit file to Garmin I get an error. Both run and ride uploaded to Strava and TP, its frustrating!


(Evan Aube) #14

Same here. It was working fine until last night’s workout which uploaded just one to Strava and Training Peaks but not Garmin Connect. Attempted to import the files from Zwft, TP and Strava without success. I suspect the issue resides with GC, not any of the other platforms.

Anyone figured this out yet?

Update: I have emailed GC support and will advise of the response when it comes.


(Venkata Subramani Renduchintala) #15

Any update ? I am having same issue… for 4 weeks now.


(Remko Peters7351) #16

Same issue here (although I didn’t try to upload it to strava). In C:\Users\rpete\OneDrive\Documenten\Zwift\Activities I see my fit file from totday (21:11) but also a file called inProgressActivity.fit for (21:07). They are also the same size.

Is this file related to the problem? And what is it doing?


(Ana) #17

Same here since last GC update. :roll_eyes: Manual uploading gets an error.
No problems uploading to Strava or TrainingPeaks.


(Evan Aube) #18

I heard back fro Garmin Support fairly quickly.

They said to disconnect and reconnect the integration with Garmin Connect from Zwift. I have just done that and will be doing a work out tonight, so I’ll report back after that.

Anyone else tried that? Success?


(Evan Aube) #19

Verdict: Disconnecting and reconnecting Garmin Connect in the Zwift connections menu seems to have solved my issue. Tonights workout uploaded to Strava, Training Peaks AND Garmin Connect without issue.

Hope this helps the other who were experiencing the same thing!


(Nils) #20

Did you also get the activity you lost in the first place?
br