Zwift with Gravat2 - ERG not working

Hi there,

I just installed my Gravat2 (45387-181), V0.124, SN0130376156491 // ZWIFT (PC, Win10 Pro, Zwift version 1.32.1 106405) setup at home. When opening ZWIFT I connect to the Gravat2 through a USB-BT addapter and in ZWIFT it’s set up as “Power Source (45387-181 174)” and “Controllable (45387-181 174)” as you can see in the attached pictures.

The issue I’m having is that the ERG mode is not working. So when I’m riding an interval for example, ZWIFT when changing Wattage is asking me to set the Wattage, instead of the Gravat2 increase or decrease the load on the rear wheel and me having pedal harder or lighter and change gears as required.

How would I fix this issue? I did see the ERG radio button before starting an interval training, but no matter if I put it on or off, the interval training is the same as described above.


Hi @Pieter_Ramaekers

Welcome to the forum.

I would first start by looking if some other device or app is not connected to the trainer and trying to control it.

Hi Gerrie,

Thanks for your reply. I’ve disabled all BT devices around the trainer and it’s still doing the same thing.

I’ve also just installed ZWIFT on my Android phone (Samsung). The ZWIFT version is 106405. Here it does exactly the same. When I start a training, the Gravat2 does not set the load of the workout. I need to increase the cadence (if staying in 1 gear) significantly to reach the requested Watt.

Is this an issue with the Gravat2? It has the latest Firmware installed.

1 Like

One more thing I think of, are you in a high gear so that the trainer is spinning very fast. Some trainers need a lot of “wheel” speed to be able to create resistance.

Do you feel resistance when you go up a steep climb in free rides?

Hi Gerrie,

In free cycling, it’s the same. The load (watt) goes up as i go in heavier gears, but the kph speed displayed does not change much. Also there’s no change in load when there is a hill…

I don’t know what to do.

Also, it’s the exact same on my PC as on my Android phone…

Did you pair the trainer with anything else, any other app? For calibration, for example?

If so, make sure you unpair it from those other apps. Don’t just disconnect, unpair it. I had issues with my Saris–when I pair it with the Saris app for calibration, I have to have the Saris app forget the trainer entirely before it will work correctly with Zwift. Even when the Saris app isn’t running–if it’s still paired in that app, it causes problems.

Got the same problem. Zwift cannot control load on Gravat2 using Bluetooth on iPad and MacBook.

  • connect power to gravat2
  • controller gravat2
  • difficult 50% and tried adjusting to max
  • tried on free ride and workout with erg on. I didn’t feel any load adjust, only constant load on the trainer

Tried calibrating my gravat and test adjust load on Magene app which works normally.

This is happening for me as well. There is another thread also discussing the same thing.