Zwift will suddenly shut down after new ver added Makuri map

Win10 Professional ver:

Zwift version:

Microsoft Edge VER 90.0.818.66 (64 bit)

Zwift always steady running in win10 before.

After zwift updated to version with new world Makuri Island, Zwift (ZwiftApp.exe) would suddenly shut down( crashed).

I don’t know how to said in native English, it is the same effect like game process forced to ended by the task manager.

I tried update drivers, reinstall zwift, fix visual runtime, all efforts don’t work. It seems the real problem is comes from zwift itself.

I have no apple MacOS to compare, now it looks like I have to pay to become an Apple fan!

:neutral_face: :expressionless:
where is zwift employee or forums support…

Hi @St.Barths_NEO2

Have you tried to uninstall and reinstall the zwift app, also have you updated all your graphics drivers.

Yes, dear Gerrie i tried,mentioned upstairs ↑

desperate, have bought an 2020 8th Gen iPad, waitting its delivery…

Oops my bad sorry. I did not see that part.

It is strange because most windows users don’t have that problem.

it unlikely related by DNS or fiber optic service right? i use aliDNS all the time, and it nothing went wrong before.

I had tried ride around few minutes, half hours, just get into the maps, it would shut down in anytime.

I play another visual ride platform, everything fine, nothing went wrong.

It seems cause by zwift update, service connection result in user side crashed

Apple iPad is going to be my last try.

my sexual & age items are wrong.
but i think those mistakes won’t let me get into such trouble

For that you will have to submit a ticket: Please file a Zwift ticket. Contact Us - Official Zwift Support | Zwift

1 Like