Zwift rides/runs not saving to Garmin


(Vincent) #1

Update #1
We do apologize for the inconvenience! We’ve had delays on uploads to Garmin and are working to improve that delivery speed and will be reprocessing those activities. So any activities over the past few days that have not yet been uploaded will not be lost and will eventually be processed. All new activities should be uploaded without issue.

Hey Zwifters,

We’ve had many reports of users being unable to upload their rides to Garmin. It’s a server issue that we are currently investigating in attempts to fix. The rides/runs not saving can be sporadic, with you sometimes successfully uploading.
You can upload your rides/runs manually by using the steps in this guide: https://support.zwift.com/en_us/can-i-upload-my-.fit-fileactivity-to-a-third-party-site-BkWegRkWSm

We will update this thread as soon as we receive new information. Thank you for your patience!

[SVR-4721]


Zwift won’t upload to Garmin Connect
Activity won't quit, rides won't upload
Zwift won't auto-upload to my Garmin Connect anymore
Delays uploading ride data
Garmin Connect sync not working anymore
(Derek) #2

Thank you for creating a Known Issue thread for this. I’d like to add that in all of my cases I also tried manually uploading to Garmin Connect (GC) after noticing the auto-upload did not work. It always complains that the FIT file is corrupt without any real reason.
Here is the latest failure for me - 2019-02-13-14-45-41.fit

and here is the JSON status response using the uploader on GC that doesn’t have any specific error message:

{
  "detailedImportResult":{
    "uploadId":30320234628,
    "owner":6864033,
    "fileSize":"",
    "processingTime":"",
    "creationDate":"2019-02-13 23:18:51.130 GMT",
    "ipAddress":null,
    "fileName":null,
    "report":null,
    "successes":[],
    "failures":[
      {
         "internalId":null,
         "externalId":null,
         "messages":[
           {
             "code":500,
             "content":"An unexpected error occurred while processing the file."
           }
         ]
      }
    ]
  }
}

(Vincent) #3

Thanks for this Derek! I’m forwarding your post over now


(Derek) #4

Just to follow up with my original response here is the fixed file from someone over on the Garmin forums (which just got a blank status response back – HTTP status code 201)

2019-02-13-14-45-41-fixed.fit


(Adam) #5

Hi, I don’t know if this’ll help but I’ve consistently had issued for a few weeks now.
Any time I just do a free ride it uploads just fine. If I do a workout it fails.
I only do free rides and jon’s mix and this has happened repeatedly about 5 times now.
Garmin don’t want to help as the data isn’t created by a garmin device.
I can fix my fit files but naturally I’d rather not have to!


(Kyle Duffy) #6

I had this issue months ago and it resolved itself. My zwift ride this morning did not autoupload to Garmin connect again. I manually added it but the information in the tcx or gpx are not complete on the information. Love if there was a way for you guys to push uploads on your servers once you fix the problem so any rides that didn’t get uploaded make it over to Garmin connect.


(Kyle) #7

Today is my first time with this issue. When will it be fixed? Causing me major frustration and anxiety!


(Claus) #8

I’ve been having this problem as well as described in this other thread, where I was guided here:

Still no luck getting anything to sync to Connect - almost 2 weeks since a single ride succeeded for me :frowning:


(Claus) #9

While we are waiting for this to be fixed (still fails every time for me) - does anyone have tips for getting the .fit-files from my.zwift.com uploaded to Garmin connect? I have tried, but just get an error every time (have tried with several different activities and two different browsers…)


(Steve) #10

First time for me today… loaded to Strava… When I closed the Win10 machine, it was"Update then Close". Pending updates seen to be able to screw things up. I’ll see what happens tomorrow…


(JK) #11

for unknown reason my ride mystically loaded to Garmin this morning automatically upon completion . let’s see what happen next ride.


(Steve) #12

strange… yesterday’s Zwift ride showed up this AM on Garmin Connect but today’s Zwift run is still missing🤔


(Paul) #13

Question. Are you syncing to Strava and garmin?


(Steve) #14

yes and the activities show up on Strava


(JK) #15

Strava never fail. It’s Garmin.


(Jeff) #16

Just adding my two cents here. I am using the windows 10 app and have it configured to upload to both Strava and Garmin Connect. Starting about a week ago my rides stopped syncing to Garmin. They show up just fine in Strava. I am able to download the .fit file from Zwift and manually add it to Garmin without any errors. I haven’t tested this theory yet but all of my rides for the past week have been longer than an hour, whereas previous rides where shorter. Thanks for the help Zwift team!


(Popuko) #17

Does anybody know whether an activity is uploaded manually or automatically onto Garmin Connect would produce any substantial difference? I’m asking this because of remembering GC used not to add the “sourced by Zwift” mark for any manually uploaded activities.

The only difference noticed so far is the activity title being plain “Virtual Cycling”, rather than a Workout name.


(Shannon) #18

Same issue for me, it only started happening last week - prior to that I was uploading to GC and Strava without issue. Also if I try to manually upload the .fit file to GC it fails too.

I’m using a mac.


(E) #19

I would like to add my voice to the upload issue - I have not had an auto-upload to Garminconnect for about a week. Tried several times to reconnect without success.
Please provide an update on the fix.


(Kyle) #20

Any update???