Zwift ride not uploading to Strava or Garmin


(Dexter Chatterton) #1

hi Guys,

Since the new update 1.0.27910 my rides are not saving to Strava or Garmin, i’m using an Apple TV.  It gives me the option to save it saves the ride to zwift but does not save it to Strava or Garmin.

is there any way of manually doing this with an Apple TV to get around this problem.

thanks

Dexter


(n eed massage) #2

Issue is back; I had this issue today with Zwift /  MacOS. It was fine 2 days ago.

 

(I manually uploaded the .fit file to Strava and it worked out.) 


(. ZwiftZone) #3

Hi Guys

Yep, same as above, today’s ride 21/07 did not save to Garmin or Strava. I downloaded the .fit file from Zwift but that file would not upload to Strava (error msg about a problem with the file).

I uploaded the Zwift file to Garmin and that went OK. I then downloaded that file from Garmin and was successful in uploading that file to Strava.

When riding Zwift I noticed the Alpe section time data, usually on the left of the screen, was missing. <sigh>

I also noticed I received 4 ‘clean’ pictures amongst my usual five or six data laden pictures in place of the usual single image.

I’m not sure if this is connected but Windows displayed an message saying an app had changed some default settings for pictures. Windows tells me it has returned the settings to default.

All this after the update today.


(David K) #4

I’m sorry to hear rides aren’t properly uploading to Strava or Garmin. Zwift generally won’t upload to third-party websites if your rides are under 2 kilometers or aren’t longer than 10 minutes. As long as the activity upload to the Activities section of your Zwift Dashboard, you can download it and manually upload it to third-party services like Strava and Garmin Connect.
https://my.zwift.com/
https://support.zwift.com/hc/en-us/articles/202257019-Can-I-upload-my-fit-file-activity-to-a-third-party-site-

If that doesn’t seem to be the issue, you can also access the Connections section of your Zwift Dashboard, disconnect links to your third-party fitness sites, refresh the webpage, and reconnect with them by entering site credentials again. Afterward, log out, then log back into Zwift.

If you’re rides still aren’t uploading, please let us know so we can open an email support ticket and possibly request logs. That won’t work on an AppleTV, but it would allow us to involve our Tier 3 team to look into possible software concerns.


(Dexter Chatterton) #5

hi David,

thanks for that I disconnected the Strava connection and re-connected it so far it seems to be working.

Also thanks for the manual link to upload the .fit files this is a good work around. :slight_smile:

regards

Dexter


(David K) #6

Awesome! I’m glad that worked. Please don’t hesitate to reach out to us with questions when they come up. We’re always around and more than happy to help!


(frank Andreasen.VTri[DBR](D)) #7

im still having this issue today ?? 
my running workout uploaded instantly to Trainingpeaks and garmin connect and also to myrun cloud software but now after more than an hour it has still not synced to Strava :frowning: strange thing is though that yesterday i did  a ride and it was connect that didnt sync but strava worked