Zwift Play Controller connection issues [1.43, 1.44, 1.45, 1.46]

Unable to steering to the far right during this sprint. I was holding/tapping trying to get my avatar to go right to follow the draft but he didn’t do so. But after the sprint he nose dive over.

Is this being investigated? It’s an issue for me with 1.2/ 1.47, W10

Yes. This should be fixed in the next full version release.

1 Like

Hi @Rowdy, tried to calibrate my controllers - Fails at the first step. When I push them left I dont get a vibration as per the instruction.

The firmware update did not fix my problem. The Zwift play controllers disconnect every time I use them, or they connect to my Zwift app on my phone. The advice given is to disconnect all other Bluetooth devices in the area. I don’t feel that a reasonable suggestion. I want to use things like wireless headphones and a wireless keyboard. I should be able to do so and also have my Zwift Play work.

1 Like

Don’t want to speak too soon. I’m using latest firmware, game version and Zwift Play disconnects in under a minute every time, disappears from the HUD (except side list), and buzzes intermittently throughout the ride, presumably trying to connect. Both controllers can steer periodically and Y, Z buttons work. But equally there are times when everything is disconnected.

I have been following the threads, attach the controllers to power, delete the BT devices on the PC, and bought a long range dongle.

Lost the ZP connection almost immediately as usual. But went back to the pairing screen, and reconnected. This time it held until the end of the ride. Next session, I wanted a RP ride, so I just went to start a free ride in the same world, steering disconnected as usual, went back to the pairing screen, reconnected, teleported to the RP and held the connection until the end. No idea if this is all just coincidence. But will keep monitoring. It’s the first continuous rides with ZP connected since I bought them and several fw updates.

Latest firmware on my Zwift Play has rendered them unusable. I can’t get them to connect to Zwift on macOS via BT at all anymore. Though they intermittently show up, they never establish a connection with haptic feedback confirmation.
New and disappointingly, if I try connecting them in the companion app before launching the game, they disappear from the companion app when the game map loads in the companion app and and thus I cant even pair them with my phone. I am tired of wasting precious time trying to make the stars align to get this product to work. :-1:

I wish I had seen this earlier. I kept getting my HR zeroed as well. I just bought a new HR strap because I thought mine was busted, though it still worked with my headunit and phone app. I guess I trusted Zwift more than the Viiiiva. How unpleasant of an experience this saga has been.

Want to see anyone else getting disconnect and reconnection with zwift play in 1.47.

@Rowdy Just wanted to follow up - just did the latest update - and the controllers worked without me doing any workarounds - Connected without being “plugged in” all functionality was as expected.

Thanks to the team for getting it sorted :+1:

1 Like

Thread title should be updated to include the latest versions. This is ridiculous. I’m pretty close to ending my Zwift subscription, it just seems like a time sink at this point.

Zwift Play Controller connectivity is still not working reliably.

Zwift Game Client: 1.48.0
Zwift Launcher: 1.1.10
Zwift Play Controllers: 1.2.0

Watch what happens for yourself:
youtu .be/ pXRVGk3KVVE

Morning. I cycled for an hour and a half this morning and my Zwift Play controllers literally disconnected every 30 seconds, a mixture of left and right and sometimes both.

Everything else works faultlessly, so it has to be an issue with the zwift play controllers.