Zwift Play - Brakes engage mid session

I contacted support and they advised me to recalibrate my left controller. It seems to have worked for now, although I’ve only done 1 ride since the recalibration…

Left Controller Calibration

Follow these steps to calibrate the left controller:

Press and hold the :arrow_backward: and :arrow_forward: navigation buttons for 5 seconds.

➤ The LED on the remote will turn solid white.

Press the analog stick to the left until the controller vibrates.
Press the analog stick to the right until the controller vibrates.
Wait until the controller resets.

I had the left controller randomly apply the brake mid-ride a few times over the last couple of weeks. I am not sure the issue is connected to sweat or moisture since turning the controller off and on resolves the problem.

Interestingly, when contracting support via chat they said it wasn’t a known bug…

The simplest solution is have the option to disable braking, it really serves very little point anyway.

I agree with your suggestion to leave the option to disable the play controller’s braking function to the user: it is quite useless and, especially in races, can be severely counterproductive.
Since this forum is also frequented by developers, and since we have repeatedly been asked to post hardware and software issues here, I wonder how it is possible that this serious deficiency has never been listed among the known bugs awaiting resolution.

To the developers: please let us choose whether or not to activate the braking function when the play controllers are on.

I had this happen a bunch on Tuesday’s ride. Honestly, these controllers are trash.

1 Like

Breaks came on during tour de zwift Scotland, was unable to complete event. Please fix this!!!

This happens for me now too, the right controller is to blame. :frowning:

The solution would be to disable the braking function if possible because it is quite pointless.

Turning the controller off didn’t resolve it. I suspect it needs recalibration- what’s the process for the right controller?

I haven’t tried the reset process yet.

Edit: I tried the recalibration procedure which fixed the problem completely.

I have been fighting this and was going crazy trying to find out what was going on in zwift. I have been blessed with not many bugs, but after 4 or 5 rides where I couldnt move at all. It was only happening off and on from time to time.

I am ashamed it took me 8ish days to figure it out. I had noticed everytime my watts, cadence, hr were all showing but I wasnt moving. Today was the day when I noticed the bright red lights were on and keeping me from moving. I disconnected the zwift play controllers and wham. I am back to moving again.

I ask please could you just disconnect the brakes? I have tried the reset of the controllers and it did nothing. I liked the rideon button and quick access to everything, but now I will just go back to the companion app.

Edit: Mine didnt start midride. Mine always started when I started my rides whether free rides or group rides.

Edit: I never touch brakes or steering from the zwift play controllers. I control movement from the neo bike

After some time during which I had been spared from this bug, it happened yesterday after I had finished a training session. At the end of the series, the brake automatically engaged, and I had to turn off the right controller. I don’t think the bug is due to wet internal circuits, but rather to a software issue that should be resolved once for all now, after st least 6 months.

Ill put this here as well. It is just a copy and paste from the companion app freezing

I am also having problems with zwift braking using the zwift play. I normally let them stay green but decided to turn them off after my companion app locked up 2 more times. I dont know what kinda voodoo happened but after I turned the zwift play unit off. I never had another problem. I could chat to my hearts desire, my screen on the companion app never froze, and this might help solve the software problem with the zwift play. I have no idea how it all ties together, but I am now 100% positive it does with todays testing and positive outcome with no brakes and no companion freeze

Just to add to this conversation. This happened to me yesterday during ‘flat is fast’ race. Brakes came on after 10 minutes ish.
Previous to this I was doing a warm up workout which turned off brakes at the start and back on at the end.
Nothing was right from the start of the race, play controllers were connected but steering stopped working (which is the only reason I use them). The avatar seemed stuck in an upright position with legs not moving like normal. I seemed to be pushing way harder than normal at the start (could have been me :wink:)
To be honest I should have restarted everything and did the race another time maybe and it might not have been the play controllers, it could have been a connection problem. I just thought I’d mention here.

I’m having the same issue here. Today it prevented me from riding immediately upon joining zwift. Restarting, shutting down and restarting, rebooting the phone, reconnecting all network cables, re-pairing, none of these had any effect. To get back to riding i had to unpair the Play controllers and immediately the braking stopped. This has happened to me multiple times in events. I followed the instructions to recalibrate them and updated their firmware but neither has fixed the problem. I pair my HR and controllers through the phone and use a direct connect to my Wahoo Kickr.


Same thing happened to me today. All firmware is updated.

Just to report this has happened to me a few times over the last few weeks. I haven’t recalibrated but given my experience, recalibration followed by a ride where the problem doesn’t happen would not be enough to consider the problem solved, because it has happened on various rides days and even weeks apart from each other. This also means it has happened after at least one Zwift software update and at least one Zwift Play firmware update.

If it’s possible, an alternative approach (apart from actually fixing random braking) would be to give the option to disable braking altogether. I use Zwift Play to steer, navigate menus, give ride ons, and trigger power ups, but braking was never an intended use case for me and even the fact that it is possible makes the experience less enjoyable, because I have to be careful not to press the brakes by mistake while steering, which is not at all unlikely when doing this at the end of a race, between a high heart rate, the rocker plate moving everything and the concentration focused on the other riders.

2 Likes

Same here, I have the latest firmware version 1.2.1 and I have recalibrated my controllers twice before when the braking problem occurred, yet today while racing Tour de Zwift the right brake engaged on its own. :angry:

I will talk with Zwift support and let you know if I have any news about this issue

Just upgraded to firmware 1.3.0

I have had the problem as others, and I was wondering if anyone has experienced the same issue with 1.3.0??

Is the problem with sudden breaking now gone, or does it persist?

Only issue that i had would be my avatar would just go left to the middle of the road, and stay there.
If i push to steer right, it would move right, but then when i leave go of the paddle, it would move back to the centre of the road.

I think i know what may be causing it.
It only happens when i push on the up arrow (i think twice), and or push the up arrow and the left arrow quickly.

I turn if off, wait a few secs, and then turn it back on, and the problem is sorted.

Hope that info might be of help.

There’s a topic for that issue if you want to weigh in on it

I gave it a try again after the latest upgrade a few days ago, including Zwift and firmware. It’s still happening. This time it happened when receiving a ride on and pressing Z to give a ride on back, the avatar would brake while pressing Z, and the brake would stay enabled until I pressed the steering button (so, the outside part of the same physical button).

To clarify, this is not the only situation where I’ve had the problem, as it’s also happened in the middle of a ride without pressing anything, but I haven’t been using Zwift Play enough to keep testing.