Zwift not recognizing my active membership

Hi all,
I have a membership that I just re-activated this month but Zwift on Mac OS X and the app on iPhone do not recognize it. I get the Trial expired message with an option to upgrade. Tried uninstalling and reinstalling, and have only one account in the household.
Would like to get this up and running quick cause I’m missing out on the TDZ.

I also contacted Support but they’re not all that helpful yet.

TIA all!

I have a membership that I re-activated as well. Got confirmation in the app (using iPad Pro) and cannot figure out how to get moving as it is recognizing my bluetooth devices and says everything is connected properly.

This has been nothing but frustrating and zero help from support.

What trainer are you using, maybe a firmware update is needed?

Dan, not Matt, said he got confirmation on his renewal and can’t get his avatar moving despite being connected via bluetooth. Sounds to me that it is a setup issue, not his membership. I replied and quoted Dan, not the OP.

Yea, my trainer works fine and Zwift connects to it no problem. I was able to do the first stage of the TDZ, but then my trial expired and now it won’t recognize my paid subscription.

Hi @Matt
The way your name is showing up on this forum, with just a first name and no in-game username following it makes me wonder if you ever changed your in-game username after you created the account?

Or - if you had changed the email address associated with the account after you signed up? Both of these would affect your account, which in turn affects how your name displays on this forum.

Are you able to log in to The at Home Cycling & Running Virtual Training App
Please double check your email address and password, maybe even try resetting the password. Then log in to the game app using the new credentials.

Not sure why, but I ignored the connected devices (wahoo cadence and speed) and then reconnected them through the app and then it started working. Unclear as to how it can recognize them when I launch the app and then doesn’t record them as being used.

Hopefully this is not an ongoing issue.

Thanks for all who replied (and anyone I may have sweat my ass off trying to catch on my earlier ride :stuck_out_tongue:

I have not changed my in-game username since last winter, nor my email address nor password. I tried resetting my password just now but that didn’t work either. I can log into my profile online and that says I’m a paid member.


Check your PM. I will send you temporary password

1 Like

So… nothing worked.
Tried uninstalling, deleting Application Support and Preference files, and reinstalling.
Tried resetting password.
I finally purchased a second subscription through iTunes and it worked. It then replaced the subscription payment in my profile from Credit Card to iTunes.
Thanks all for all your help.

I’m in the same boat here. Paid for my membership via iOS App Store a few days ago and my avatar is still locked. All my Bluetooth devices are working perfectly. I’ve tried to use Zwift on my computer and phone and I’m still categorised as being in the trial period. I have paid for a month subscription.

1 Like

@Timothy_Tippins on your iPhone log out of Zwift and force close it. When you load it up again there should be an option to restore subscription (can’t remember exactly where) but this happened to me once. After I did that all was working fine again.

1 Like

Thanks Daniel, that worked.

Thank you. Worked for me too

Hi all,
I need help!!
I registered Zwift account in 2018 and have not been actively using it and it is still on free trial status.
I am recently wanting to get back to zwifting but could not do anything as my avatar is not moving. I tried various options as follow:

  1. un install and re install zwift apps ( i am using Hua Wei P30 pro phone)
  2. my trainer (tacx vortex 29) is connected (with green tick) on the zwift apps"
  3. i also purchased the monthly subscription and showing " subscription purchase status is pending with a note stating… member since March2018 and free trial not started.
  4. I have also contacted the support team, who has kindly help me via chat service but also ran out of idea.

I still cant get my avatar to move…

Please to hear your thoughts and solution to this.


I was raging when this happened to me as I couldn’t find a fix but now have:

When you get the “join now” box appear in the app don’t click join now. Instead scroll down in the box and there will be a “reactivate subscription” hyperlink. Click this and hopefully all should be good👍

Hi, I’ve been using Zwift for multiple years. I reactivated my subscription on iOS; however, I do not see the ‘reactivate subscription’ hyperlink in the bottom left corner when I log in (I have seen it in past years and it worked). I’ve tried logging out and back into Zwift. I’ve tried deleting and re-installing the app. The link never appears. How do I get Zwift to recognize my paid subscription?

1 Like

I ran into the same issue today (re-subscribed on my iphone, opened on my mac, and nothing). I reached out to Support via the chat function and they had to manually reset my account. It now works again.

I hope this helps for anyone still dealing with this.

If you’re on Apple subscription, try a quick ( at least 5 minutes ) ride on an IOS device. Save, Log out, Force Close App, Do another 5 minute ride…

When my IOS subscription doesn’t sync with Zwift on my Windows machine, this usually works within 10 - 15 minutes ( and yes it’s fWord annoying :roll_eyes: ) :blush: