Zwift not controlling resistance of Tacx Vortex


(Julian Grijns) #1

I have just received a brand new Tacx Vortex. I purchased a Garmin Ant+ dongle to use on my MacBook Air. Everything connects fine. I updated to Tacx 3.1.13 with the Tacx Utility App and I can control resistance of the Vortex using the Tacx Trainer App.

In Zwift, it sees the Vortex immediately and I can connect to power, speed and cadence readings immediately. The big problem is that Zwift is not controlling the resistance of the Vortex. There is no change at all.

I’ve tried everything including unpairing and repairing, unplugging the Ant+ dongle, unplugging the Vortex and replugging it back in. Rebooting the MacBook. Nothing seems to work. I also moved the MacBook Air to within 2 feet of the Vortex but I know that’s not the issue because it’s reading the power, speed and cadence fine.

The strange thing is that it did work once. I had stopped pedaling, unpaired the power reading and selected something else that showed up in the pairing menu that read “power” instead of “smart trainer” and that worked so I thought I had fixed it. But now on the multiple following rides I tried doing the same thing as well as all of the above. Zwift simply does not want to control the resistance of the Vortex for some reason. I’m quite disappointed.

And yes, I’ve read similar posts here and tried everything with no luck.

Any ideas are welcome!

 


(Carl Nolan) #2

If you have started any of the Tacx applications (Utility App) you need to ensure that these are closed down correctly, as they may have hold of the trainer using Bluetooth.

https://support.apple.com/en-us/HT201330

Once you have done this disconnect the trainer from power for 30 seconds and then you should be good to go.

If you don’t do this you can see the data from the trainer but Zwift will not be able to control it as the Tacx applications (not being completely closed down) will still have control of the trainer.


(Julian Grijns) #3

Thanks Carl. I’ll give this a try although my phone was no where near the trainer. Will report back soon. 


(Julian Grijns) #4

Carl - I closed all apps, shut down bluetooth in my iPhone as well as my MacBook Air. I even shut down my iPhone. I unplugged the Tacx unit for 5 mins, plugged it back in, started a Zwift ride and still not resistance control. I tried multiple other things as recommended on this forum. After 45 mins of trying I still have no resistance control on the Tacx Vortex.

I tried the Tacx training App and again with bluetooth it controls the resistance on the Vortex like it should but Zwift is unable to.

Only thing I can think of is that I have a bad Ant+ stick but its brand new (purchased a Garmin Ant+ - see below).

http://www.amazon.com/gp/product/B00CM381SQ?psc=1&redirect=true&ref_=oh_aui_detailpage_o00_s00

So, I am out of ideas and very disappointed.  Was really looking forward to using Zwift this winter.

If anyone has any ideas at all what could be happening that would appreciated.


(Julian Grijns) #5

OK, here is what I also tried.  I deleted the Swift App on the MacBook and reinstalled it. I selected Tacx Vortex as my trainer and went through the setup options. When I start the first ride the Vortex looks to connect to Zwift, it now gives me an option that is called “FE-C Trainer 21394” but after about a minute that option disappears and is replaced by “Ant+ Trainer 21394.”

I thought that was it. I moved the MacBook right next to the Trainer and still not resistance control.

I’ll give it a few more days of effort, but may just have to return the Tacx Vortex and get a Wahoo Kickr Snap and try that.

This is quite frustrating!!


(Eric Oshlo) #6

That’s interesting. I have a Tacx Vortex and it works just fine. The first time I paired it, it showed up in the Controllable Trainer section as an FE-C Trainer but every time since has shown up as a Trainer with its ANT ID similar to what yours appears to be doing. 

I’m afraid I can’t offer much additional help as I’m out of town and won’t be back near my trainer for a couple weeks. It’s possible that it’s the ANT+ dongle. Sorry I can’t be more help at the moment other than to confirm that the Vortex will work properly & change resistance based upon the course gradient in Zwift.

 


(Julian Grijns) #7

OK, today I did an FTP test. 45 mins with a 20 min FTP.  Zwift controlled the trainer fine on this test, increasing the resistance during the FTP and decreasing it at the end. So, clearly Zwift is able to communicate with the Tacx Vortex.

I then went immediately to a regular course and it still does not control resistance on hills.  So, I’m completely befuddled now.

I’ve ordered a different Ant+ USB stick just to see if that’s the issue.

Any one else experience this and have any ideas as to what could be going on?


(Eric Oshlo) #8

I doubt this is the issue, but be aware that Zwift will control the trainer based upon course gradient (hills) only in the Just Ride, or Ride with Someone modes, not if the workout mode is activated in any way, such as free ride…


(Nikita Shvetsov (Multi-Team)) #9

Check “Trainer Difficulty” slider in settings menu.


(Julian Grijns) #10

Eric - thank you, thank you, thank you!!  I’ve got no idea why I did not stop to think about that absolutely simply issue.  Just got on the bike and that was it!!  Perfect resistance control!!

Now I’ve got no excuse this winter!!

Zwift on !!! 


(Victor van Essen) #11

I am also experiencing problems with the resistance using the Vortex Smart. One of my friends has the same product, so we compared our settings. His settings page shows ‘trainer difficulty’, where mine shows ‘virtual power mode’. So I assume my device has the wrong set up? How can I change this? Any suggestions?

Thanks and ride on!


(Carl Nolan) #12

Check this out:

http://zwiftblog.com/vortex/


(Eric Oshlo) #13

If you are seeing Virtual Power mode, it sounds like your Tacx Vortex is not paired as a Controllable Trainer in addition to being paired as a Power Meter (presuming you do not have a separate power meter) on the pairing screen. 


(Mikael Vesterberg Vegan SZR) #14

Thanks Eric for the help. It was the Virtual Power mode that somehow got enabled for me. Disconnected och paired the Vortex again and paired as a Controllable Trainer. Now it works like a charm. Again, thank you!

 


(Andy Parkes) #15

I have the same problem. Tried everything suggested. Eventually I found the solution was to connect to the trainer via mobile link bluetooth, not via ANT+.

Happy with that solution, but interested to know why ANT+ FE-C control doesn’t work?  Anyone?


(Miha Stokelj) #16

Hi. When I ride a race with a longer uphill the power and resistance of my vortex smart drop after few minutes of uphill. It looks like it is loosing resistance and  no matter how hard I pedal power doesn t go up. What could be a problem? Tnx