Zwift not controlling cycleops Magnus and failing calibration.


(Nathan Bernhardt) #1

Hi,  I have a cycleops Magnus connected by an iPad Pro.  Tonight it wasn’t increasing or decreasing the resistance during a 12 mile free ride (not a race or specific workout).  It’s juse getting cold now and have only used it a couple of times before but it was working with Rouvy just fine.  I updated the firmware, uninstalled and reinstalled the app, to no avail.  The cycleops passed calibration in Rouvy but in trying to calibrate it with Zwift, it would stop at 3 or 4 or 2 mph and then fail and time out.

Any suggestions on what to try?  

Thanks!


(Nich Tam) #2

This is the same problem that Magnus users experienced a couple of months ago. It is supposed to be fixed in the latest revision but the problem is still there when I tried the calibration routine on my IPhone. 

I did the calibration as instructed and stopped peddling when I reached exactly 37 kph and allowed the rear wheel to spin down. When the wheel stopped the speedo was stuck at 6 kph and the calibration timed out and “failed”.

As a result of this process I had to wait almost an hour for the “you’ve missed your calling as a pro cyclist etc” banner to go away because the failed calibration resulted in my putting out a wattage of 4096 WATTS!!!

I then tried the same calibration routine using the latest Zwift App my Mac OS computer and the Calibration passed!

After this successful attempt at calibrating using Zwift instead of Rouvy my wattage has gone up by around 10 Watts which I hope is more accurate reading of my ability. :slight_smile:

However the bottom line is that calibration still seems to be an issue on iOS.


(Nathan Bernhardt) #3

As a follow up, Zwift was controlling the resistance on my trainer tonight.  I think having the trainer unplugged perhaps did the trick.  I didn’t try calibrating again.  Seemed about right without calibrating.


(Sloan Watson) #4

I haven’t done the calibration for my Magnus, but I have a 4iiii crank meter and I noticed that zwift was inflating my watts over the crank significantly, say 35%  but I wasn’t tightening the roller to the wheel until it clicked. It was under light pressure.  When I tightened it all the way to the click, the watts on Zwift came down and gave me figures consistently within about 5% of my crank meter, so I’m good.


(Brian Cotterill) #5

I am having the same issue with my Magnus not providing resistance on Zwift.  Calibration on Rouvy provided resistance and passed.  The Zwift calibration fails as the free-wheeling stops at about 3-4 mph and can not get to zero.  I have the tensioner screwed down as instructed, using a 35mm road tire.

I am using an iphone 7 to connect and mirroring to a flat screen through an appleTV.


(Jazz K) #6

I am having the same issue, I have cycle ops magnus trainer and the Zwift calibration fails as the free-wheeling stops at about 3-4 mph and can not get to zero, i changed the rear wheel as well and loosen the wheel but nothing works, is this issue related to the Zwift app?. I used the the app on Iphone 6, Mac pro and ipad , but the calibration fails. 


(Jeff Ludwikoski *USMES* EVR (D)) #7

Same problem as everyone above.  SO disappointed! Purchased the Magnus through Zwift bundle.  Please come up with a fix soon.


(Phil Barclay) #8

Same!


(Trey Jordan) #9

I had this problem and solved it.  The magnus shows up as both magnus trainer for controllable and power.  It also show up as Saris.  Select the Saris instead of Magnus and it works.


(Jack! Mo! ALL TRI RACING) #10

Same problem. I opened ticket because this says “solved” on another thread but I can’t find solution.

Calibration stops at 2 MPH and times out, then fail.
I can sustain an indicated 400 watts easily around the course and resistance no longer changes with incline/decline.

Worked well for a year … then I saw that dang “calibrate” button.

Zwift says it is a trainer issue on another thread, and it may be … but the problem was created by hitting calibrate within the Zwift application.
Cycleops Magnus on a PC and Apple TV. 


(Trey Jordan) #11

Jack, I could only get it to work using ANT, not Bluetooth.  I could also only get it to work by selecting the Saris and not the Magnus option. I am using the ant dongle with MacBook Pro and hdmi to the tv.


(Steve Trahey) #12

Same issue here.  Brand new Magnus trainer, updated firmware.  Connected through Apple TV, iPad and iPhone via Bluetooth.  There is no resistance change during workout and the calibration fails with speed never getting to zero during the process. I am not getting the “Saris” and “Magnus” options during the setup, only the Magnus shows up.  Also have not tried ANT+ but I shouldn’t have to.  This issue seems to have been going on for months and presumably the Magnus is one of the top smart trainers being used with Zwift.  Seems to work fine with Rouvy.


(Trey Jordan) #13

Yeah, the saris option seems to be only with ANT+.  Our second Magnus which my wife uses with her iPad will not complete the calibration either. It seems to be a legitimate Bluetooth issue that has not been addressed.


(Sloan Watson) #14

I currently ride 10mins on Zwift, shut down Zwift, connect to rouvy, do my calibration hot with Rouvy because my zwift calibrations fail. Then I shut down Rouvy and reconnect Zwift. My power numbers are then reasonably close to my crank power meter. I’ve used iPhone and appletv with same results


(Trey Jordan) #15

Zwift added this to the known issues list and suggested exactly that. They just said “use Rouvy to calibrate.”


(Steve Trahey) #16

Hi Sloan & Trey,
Thanks and this does work for the calibration but I still am getting no control over the resistance of the trainer in Zwift ( but it works in Rouvy). Do you have the same issue with resistance?


(Trey Jordan) #17

As long as the Magnus is selected as both the power source and controllable trainer, it works fine for me. The only issue has been the spin down calibration.


(Adam Tanious) #18

Just bought a new Cycleops Magnus trainer.  Successfully updated the software/firmware and connected it to Rouvy where I did a calibration.  Then onto Zwift… no ability to calibrate and parameters are fairly inaccurate during my attempted rides on zwift. 

Not sure if this is a trainer issue or a Zwift issue based on all the comments.  

Essentially need to know if I switch to trainer-road or go with a different trainer (Wahoo Kickr snap)?


(Phil Clarke) #19

I’ve been using a Magnus trainer for almost a year.   I always do the calibration/spin-down within the Rouvy app on an iPhone.  I have had no issues with Zwift controlling the trainer, using BLE on iPad and AppleTV, and also ANT+ on Mac and PC.


(Trey Jordan) #20

I use magnus with mac Ant+ and it works fine. My wife uses another Magnus with her ipad and the only issue she has is the actual calibration which has to be done in Rouvy. Each work consistently well with control. The only thing I have noticed is that the power readings from the Magnus are slightly lower than my Vector 2 power meter.