Zwift [MacOS] will not connect to correct power device

Zwift works fine on my Macbook (2020, running Monterey 12.3) with my Nero Elite rollers when I ride by myself. It also works fine on my Microsoft Surface (2022, running Windows 11) with my Tacx Flux S trainer. I cannot get both computers and trainers to work simultaneously (running two Zwift accounts).

When running both computers and trainers, the Macbook picks up the Tacx Flux power instead of the Elite Nero rollers (without fail), and ONLY the power. The Macbook continues to use the cadence from the Elite Nero rollers, but it does not receive power data.

In fact, the Macbook avatar will not move unless both trainers are in use: when the Elite Nero rollers are used on their own, Zwift picks up cadence and no power. When the Tacx Flux trainer is used on its own, Zwift receives neither cadence nor power. The power from the Tacx Flux is only picked up when the Macbook is also receiving cadence data from the Elite Nero rollers.

Things I have tried:

  1. Rebooting computers. Rebooting both trainers.

  2. Paring Elite Nero rollers to Macbook first, then turning on Surface and Tacx Flux to pair Tacx to Surface.
    Same error occurs.

  3. Pair the Tacx to Zwift in the app, then tell it to “Unpair” (in hopes of getting the Macbook to ignore/forget the Tacx Flux signal).
    Same error occurs.

  4. Deleting the knowndevices.xml file from the documents/zwift folder.

  5. Renaming the knowndevices.xml file from the documents/zwift folder.

  6. Editing the knowndevices.xml file and erasing the Tacx Flux from the knowndevices.xml file.
    Same error occurs.

  7. Reset Macbook’s Bluetooth module via Terminal (in hopes of getting the Macbook to ignore/forget the Tacx Flux signal).
    Same error occurs.

  8. Deleting ALL Zwift data from Macbook (including hidden ~Library files), then reinstalling Zwift.
    Same error occurs.

  9. Update Nero Elite rollers firmware (v. 192) via the Elite Upgrado app.
    Same error occurs

Any advice would be appreciated. Please note: I do not have an ANT+ dongle, and I do not plan to purchase one. “Get an ANT+ dongle” is not a valid solution. Bluetooth has been around for over 20 years and should be sufficient (other users in the forums report using two computers and two trainers without issue).

Is there a way to tell a computer to completely ignore the signal from a trainer? As in, is it possible to tell my Macbook to never connect to the Tacx Flux?

Thank you in advance.

There is currently no option to blacklist specific trainers or devices. Have you confirmed that the Elite Nero is working correctly when paired to the Surface? I’d also recommend trying to delete the prefs file on the Macbook, unplug the Tacx Flux, pair the Macbook to the Elite Nero and try to do a ride. Hopefully this will get the pairing set up correctly in the prefs file so the Macbook automatically pairs like you want it to in the future.

Thank you for the response. I have tried all of the above to no avail.

The Macbook DOES automatically connect to the Elite Nero rollers. The problem arises when the Tacx Flux is plugged in and turned on so that my wife can use it with the Surface. If I am in the middle of a ride with the Macbook/Nero combo, as soon as we turn on the Tacx Flux, her power is transmitted to the Macbook and overrides the power reading from the Elite Nero.

Any other advice is welcome. Otherwise, please advise on how to go about requesting a refund from customer service, as this makes the software completely useless in our household.

We’re about on the edge of what I can do in forums but I do have one last thing we can try. I took a peek at your account and it looks like the signal strength on your Nero is pretty low while the Tacx signal strength is relatively strong so there’s a chance that when the Tacx starts broadcasting it creates enough interference to cause a drop out and then gets picked up by your Mac since they’re both looking for something to pair to.

Is there any chance you can improve the line of sight between the part of the Nero with the electronics and shorten the distance between it and the Mac? This should strengthen the signal strength and may help prevent this. Another unorthodox idea might be to put a fan in between the Tacx and the Mac to interrupt that signal.

Thank you for looking into this. I did not know signal strength was was recorded and could be analyzed, but that certainly seems like a plausible explanation to what is happening.

Will test these ideas out next time we ride indoors. Thanks again for the reply.