ZWIFT/ KICKR Strangeness

I have recently replaced my KICKR and use it with ZWIFT running on an Apple TV. Shortly after I got the new KICKR I upgraded ZWIFT and began to notice something new and, to me, strange.

I am riding along and come to a hill. The tension gets easier while the cadence stays the same or rises. My speed drops, which I would expect. But this all happens without me changing gears.

If I come to a downhill, the tension does not get easier, but my speed does rise.

It’s like driving a car with an automatic transmission. It automatically adjusts without me having to manually shift gears. On the bike, my tension is changing automatically without me changing gears.

Does anyone know why this is happening? Is it the KICKR or ZXIFT doing it? How can I shut it off so I’m controlling cadence by changing gears manually?


Hi Dan,

Did you Start a Workouts as you get that bevaviour?
It‘s sounds you activated a workout in ERG Mode.

It wasn’t a workout, just my own ride.

I don’t know anything about ERG mode. Can you explain it? If that’s the problem, how do I get out of ERG mode?

Thanks for the help.

ERG mode is when the trainer will always keep you at a specific target wattage regardless of how fast you are pedaling. At 60 RPM or 100 RPM the trainer will automatically adjust the tension. This is usually only used in a workout and should be off if you are doing a free ride and want to feel the hills. Also make sure you have the kickr paired correctly, are you using bluetooth or Ant+??

Hi Dan, have you tried updating the Kickr firmware to the latest version via the app? This solved my similar problems with the kickr and climb.

Thanks for explaining ERG mode. It sounds exactly like what’s happening. I think you’re right.

I believe the KICKR is paired properly. I’m using Bluetooth. Everything is connecting—KICKR, cadence and heart rate monitor.

I will check if it’s in ERG mode by going into Workouts on my next ride.

Agree with Mike, especially since it is a new Kickr. They don’t come with the current software and Zwift stays up to date.

I did update the KICKR firmware when I got the new one.

I just got on my bike and went into Ride Type. I found the ERG button on so I turned it off. When I rode after that, everything was back to normal. So that seems to have fixed it.

Thanks to everyone for the help.

I had the same issue today during a group ride. Not a workout. Also Apple TV and Kickr Core.
Where or how can I switch erg mode off? I can’t find any option to do this.

The way I found it today is to start Zwift and select a Training ride.
At the bottom of the Training screen is a button labeled “Use ERG mode”. Turn it off.

I hope this helps.

Thanks a lot.