Zwift is crashing galore

I don’t disagree with you. There’s definitely something off with the latest couple of game releases, see my various posts whinging about this forum about it.

You’re shouting at people trying to help.

@Crat_Thorax - thanks for reporting this here & for responding in a Zwift crashing during events thread that I started yesterday (here).

For anyone experiencing game crashes during events, please add your comments and details in this thread, and also submit a support ticket with Zwift…the more info we share, the quicker a fix can be identified & rolled out.

Hi @Crat_Thorax

From what I can tell, there have been various reports of seemingly excessive CPU usage on PCs since the last Zwift update and this may be resulting in things like massive FPS drops and perhaps even Zwift app crashes. I’ve reached out to a higher tech authority on the team in an effort to get more information for everyone. I’ll update you when I know more.

2 Likes

Might be something to this. Usually my PC works great. I’m on a Vega 56 too and did have some issues several months back, had updated the driver which resolved it back to normal stable system. Then couple days ago the crashing started again.

Came in here now just to see if any other reports were going around. Updated to the latest drivers in the hope of improvement (Feb 24th 22.2.3) and its totally unusable as I type now. Crashed 3 times in as many minutes, unable to even get into an event. Going to try an older driver (because I can’t roll back zwift!) and see if any ‘success’.

Since January 18th I have had numerous crashes (Windows 10, 3060ti) logs show a kernel error.

It’s not my job to downgrade any drivers. It’s their job to do proper testing for new releases, specially if there are knowen problems with Vega GPUs. My only job is to mount the bike, and start pedaling, and install all the newest drivers for all my hardware. Which happens naturally given my background as veteran PC gamer.

I’m a customer. Why do big companys in a genuine monopolistic position, use to vomit out BETAs without giving a second thought in quality assurance nowadays? It’s becoming more and more standard practice. They have so many customers, they can give two fs if some turn their back on them, due to frustration. I freaking hate it. Steam, Nvidia, Microsoft, AMD, Google…the list is big and increasing.

Summer is coming. I’ll just unsub from Zwift if I crash again this week. Cycling outside is way more fun anyways. If my money isn’t good enough I’ll keep my eyes open for more professionell providers.

Thing about how terrible it must be if you’re an amateur or pro, with an actual training shedule, that can’t be worked on because they messed up. A simple “we’re working on it” simply isn’t enough. Role back the update, fix the BETA internally, then have it released. Job done! Or even better. Not have a broken BETA released to begin with. Job done!

1 Like

Spoiler alert…

3 Likes

For what it’s worth, I’m also getting tons of crashes on a Vega56 since the last Zwift update. Rolled back my drivers, still crashing.

Agree that this is very frustrating for a paid service.

1 Like

I went back to 22.2.1 and it crashed straight away again. Left that driver in place, then clicked on standard graphics profile in Radeon settings and seems to be behaving itself so far (last night and this afternoon). Havnt gone any deeper into which aspect it seemed not to like. Zwift also had an update when I booted up today.

1 Like

Hi @Crat_Thorax

I heard back from the team and there was an issue recently discovered having to do with Events crashing that had PowerUps disabled. This has been discussed in more detail here.

From what I’ve been told, the high CPU usage/low frame rate issue is technically a separate matter, but might also be related to the app crash issue. We’ll see how it goes once the app crash issue is fixed.

Well so much for that, it’s back to crashing. It’s incredibly irritating, not just removal from a ride and disruption of training, but even the plethora of corrupted fit files I’m left with and have to decide if each one is worth the effort of running a series of repair tools to then import them into my training records.

It does however still seem mostly an issue when running Zwift in windowed rather than fullscreen mode (I like it that way when watching a movie).

post 1.23.2 update I’m still getting chronic hangs (4 out of 5 rides attempted). Also run in windowed mode (on AMD gpu with latest driver).

Hello, I am not sure if this is the right thread, but since last week, I’ve have my connection drop between the Zwift Companion app (which I made sure was updated) and the Zwift App. I use ZC to connect to Zwift App. I have been using Zwift/Kickr Core since Dec 12th and have had one or two occasional drops. This week sets a new record.

Smart Trainer: Kickr Core
Zwift app is running on MacBook Air with Big Sur OS v11.6 (apparently I need to update this which I am doing know_
Zwift App automatically updated INCLUDING today before I rode
Zwift companion app is running on my iphone. I made sure it was updated after crash 1 and crash 2. There are no updates pending
ZC and Macbook are on teh same WiFi. Nothing is different about my setup or bike/trainer location that would explain a change (i.e. I didn’t move my bike further from WiFi)

What happens when the connection drops: the blue box w/RPM, wattage shows me the connection has dropped. This has happened on events (a TdWatopia event) and free rides. Today it dropped after 25 minutes of riding, came, back briefly, dropped again. All three times over the past week, the wattage and RPMs on my smart trainer were wonky after I tried to ride again. I tried to do a spin down calibration after each time, and it could not find my device ‘FAILED’. I did two spin down calibrations after the prior to times. I gave up today. But each time I initially got the FAILED error.

Is there anything from the logs that I could look at that might explain what is failing or what is happening? I am wondering if it is a KICKR Core issue, but i can’t call Wahoo on a weekend. Heres a log snippet from when connection dropped. I appreciate any input/thoughts.

Log:
[17:58:37] Starting critical power curve search job (1997476) mTimeStamp = 1557.92859 m_lastSearchTime = 1547.90649 calculating=false
[17:58:39] [FTMS] Resending last request.
[17:58:40] FPS 24.65, -159752, 14809, 260647
[17:58:44] [FTMS] Resending last request.
[17:58:44] NETCLIENT:[ERROR] Auxiliary Controller received ‘Connection reset by peer’ (54) during message length receive handler
[17:58:44] NETCLIENT:[WARN] Auxiliary Controller failed to shut down tcp socket: ‘Socket is not connected’ (57)
[17:58:44] NETCLIENT:[INFO] Auxiliary Controller shutting down keep alive loop
[17:58:44] NETCLIENT:[INFO] Auxiliary Controller attempting to connect to phone at: 192.168.254.45:21587
[17:58:44] NETCLIENT:[INFO] Auxiliary Controller connected successfully
[17:58:44] NETCLIENT:[INFO] Sending Pairing Status of: true
[17:58:45] Chat: Ami (B2B) 4105618 (World): Lena and I aren’t taking breaks. We’re strong
[17:58:45] LIVESEG: Sending Active Segments.
[17:58:47] Starting critical power curve search job (2007506) mTimeStamp = 1567.96924 m_lastSearchTime = 1557.96863 calculating=false
[17:58:48] FPS 24.25, -159042, 14808, 260026
[17:58:49] NETCLIENT:[INFO] UDP metrics {StC Rx: 829, Rx error: 0, CtS Tx: 292, Tx error: 0}
[17:58:49] NETCLIENT:[INFO] Failed one leg latency threshold test. [min: 562, avg: 2541, max: 4763, n: 89]
[17:58:49] [FTMS] Resending last request.
[17:58:54] [FTMS] Request took too long, resetting trainer.
[17:58:54] [FTMS] Updated state from 4 to 1 and opcode from 0 to 127
[17:58:54] [FTMS] Updated state from 1 to 4 and opcode from 127 to 0
[17:58:56] FPS 23.70, -158507, 14811, 259664
[17:58:56] Phone requested profile. We know about player 3188051 but don’t have the profile yet. Still waiting on the server
[17:58:56] Phone requested profile. We know about player 4777564 but don’t have the profile yet. Still waiting on the server
[17:58:56] Phone requested profile. We know about player 573577 but don’t have the profile yet. Still waiting on the server
[17:58:57] Starting critical power curve search job (2017575) mTimeStamp = 1578.03284 m_lastSearchTime = 1568.00928 calculating=false
[17:58:59] [FTMS] Resending last request.
[17:58:59] Chat: Ami (B2B) 4105618 (World): P)
[17:59:04] FPS 22.94, -157503, 14830, 258974
[17:59:04] [FTMS] Resending last request.
[17:59:05] num=1584 NP = 94.12 IF = 0.82 TSS = 29.47
[17:59:05] Loading WAD file ‘assets/UI/WhiteOrangeTheme/JerseyIcons/JerseyIcons.wad’ with file.
[17:59:07] Starting critical power curve search job (2027650) mTimeStamp = 1588.10327 m_lastSearchTime = 1578.07483 calculating=false
[17:59:09] [FTMS] Resending last request.
[17:59:12] FPS 21.79, -156623, 14866, 258326
[17:59:14] [FTMS] Request took too long, resetting trainer.
[17:59:14] [FTMS] Updated state from 4 to 1 and opcode from 0 to 127
[17:59:14] [FTMS] Updated state from 1 to 4 and opcode from 127 to 0
[17:59:17] Starting critical power curve search job (2037709) mTimeStamp = 1598.16675 m_lastSearchTime = 1588.14929 calculating=false
[17:59:19] Chat: ena (B2B) 150928 (World): Awe thanks Ami x
[17:59:19] [FTMS] Resending last request.
[17:59:20] FPS 21.55, -156063, 14903, 257852
[17:59:24] [FTMS] Resending last request.
[17:59:27] Starting critical power curve search job (2047764) mTimeStamp = 1608.22144 m_lastSearchTime = 1598.21277 calculating=false
[17:59:28] FPS 20.99, -155623, 14937, 257507
[17:59:29] [FTMS] Resending last request.
[17:59:34] [FTMS] Request took too long, resetting trainer.
[17:59:34] [FTMS] Updated state from 4 to 1 and opcode from 0 to 127
[17:59:34] [FTMS] Updated state from 1 to 4 and opcode from 127 to 0
[17:59:36] FPS 21.01, -155229, 14969, 257187
[17:59:37] Starting critical power curve search job (2057850) mTimeStamp = 1618.30212 m_lastSearchTime = 1608.26746 calculating=false
[17:59:39] [FTMS] Resending last request.
[17:59:44] FPS 19.95, -154863, 15003, 256881
[17:59:44] [FTMS] Resending last request.
[17:59:47] Starting critical power curve search job (2067916) mTimeStamp = 1628.36743 m_lastSearchTime = 1618.35217 calculating=false
[17:59:49] NETCLIENT:[INFO] UDP metrics {StC Rx: 517, Rx error: 0, CtS Tx: 300, Tx error: 0}
[17:59:50] [FTMS] Resending last request.
[17:59:51] ZML_SendMobileAlert Succeed, Title: END RIDE, options count 2
[17:59:52] FPS 22.22, -154512, 15035, 256581
[17:59:53] NETCLIENT:[INFO] Sending telemetry…
[17:59:53] SaveActivityService::EndCurrentActivity with {activityName: Zwift - Tick Tock in Watopia, privacy: FRIENDS, hideProData: False}
[17:59:53] SaveActivityService FIT_CloseFile
[17:59:53] SaveActivityService GAME_SaveStockImage with {activityId: 1038651769887932432, worldId: 1, playerId: #############}
[17:59:53] Skipping beauty screenshot due to ZWIFT\CONFIG\IMGPREFS value: 2

System Specs
CPU AMD 5900x | GPU AMD Powercolor 6800xt Red Devil | 32 GB DDR4 Ram | OS Windows 10 Pro

Ant dongle used to connect my Pioneer PM | Bontrager HRM and Wahoo Kickr Core

On a clean purpose built system with the only two apps being run on it being MSFS 2020 and Zwift.

Everything was running fine before this new zwift version.

Snippet from Event Viewer Error log

Faulting application name: ZwiftLauncher.exe, version: 1.0.0.0, time stamp: 0x61d5e3f3
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1566, time stamp: 0x0833f2d4
Exception code: 0xe0434352
Fault offset: 0x0000000000034f69
Faulting process id: 0x1980
Faulting application start time: 0x01d83ca23c2d0719
Faulting application path: C:\Program Files (x86)\Zwift\ZwiftLauncher.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: eb9062ad-be8a-4459-873c-f977cdc348d0
Faulting package full name:
Faulting package-relative application ID:

And

Application: ZwiftLauncher.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.InvalidCastException
at System.StubHelpers.StubHelpers.GetCOMIPFromRCW(System.Object, IntPtr, IntPtr ByRef, Boolean ByRef)
at Microsoft.Web.WebView2.Core.Raw.ICoreWebView2Controller.get_CoreWebView2()
at Microsoft.Web.WebView2.Core.CoreWebView2Controller.get_CoreWebView2()
at Microsoft.Web.WebView2.Wpf.WebView2.Uninitialize(Boolean)
at Microsoft.Web.WebView2.Wpf.WebView2.Dispose(Boolean)
at System.Windows.Interop.HwndHost.Finalize()

Please get this fixed quickly. A lot of people actually use this for training and are losing training hours
Thank You

Hi @Andrew_Crabtree6697 and @Jamie_Grant

If you have an AMD GPU with the latest drivers, it’s possible that you’ve been impacted by the issue discussed here.

Here’s the fix to the Webview2 issue… I get this on an Intel Iris 655 with Zwift installed on either the Admin or user account on Win10Pro

  1. Go to Apps and Features or whatever it’s called now. Find EdgeWebview2 Runtime → Modify → Password maybe → Repair
  2. File Explorer → Downloads → grab everything in the Zwift folder (select all → Copy)
  3. File Explorer → find Zwift in C:\Program File (x86) or whatever → paste the new files right over the top of it. Replace anything that is a duplicate.
  4. Run ZwiftLauncer.exe (not the ZwiftApp.exe).

Should run fine now.

After some crash free weeks Zwift is now crashing constantly again, mostly when entering the garage.
AMD-Software-Adrenalin-Edition-22.3.1-Win10-Win11-March17

Driver ran fine two weeks ago, so I’m pretty sure the problem came with 1.24.0. And I am getting the feeling, that nobody at Zwift does any testing at all with Windows machines.

Das Programm ZwiftApp.exe Version 0.0.0.0 hat die Interaktion mit Windows beendet und wurde geschlossen. Überprüfen Sie den Problemverlauf in der Systemsteuerung “Sicherheit und Wartung”, um nach weiteren Informationen zum Problem zu suchen.
Prozess-ID: 3154
Startzeit: 01d8533086906f5f
Beendigungszeit: 6
Anwendungspfad: C:\Program Files (x86)\Zwift\ZwiftApp.exe
Bericht-ID: 906f7156-16e1-439f-9d42-8cebf5371327
Vollständiger Name des fehlerhaften Pakets:
Relative Anwendungs-ID des fehlerhaften Pakets:
Absturztyp: Unknown

1 Like

Join the club. :confused:

Yeah im using Zwift on my Pixel 6 phone again, so no companion app but at least the game runs stable.

edit: found this thread here https://forums.zwift.com/t/instant-freeze-crash-on-tempus-fugit-pc/583380

I thought the crashes on my system where when accessing the garage but when it happened, I had Tempus Fugit selected, so tahts where the near-instant-crash happens. Took another route and had no crash so far when entering the garage.

Sadly I had a Zwift launcher issues as the launcher I used was badly outdated. I have done the whole backup and reinstallation as per Zwift Support. Sadly I still get the white screen launcher which just closes, I restarted my PC, hoping that would solve the issue. Zwift started the updating screen but crashed soon afterwards. Please help