Zwift Hub no data transmission

Hi everyone,

yesterday my new Zwift hub arrived.
I was very excited! The package was very well secured, the instructions were easy to understand and the installation was no problem.

After connecting to the Zwift companion app I updated the Zwift hub Firmware to version 3.9.
The Zwift app connected to the hub with no problem.
Unfortunately no data (speed, power, cadence) was transmitted.

After contacting the Zwift support a few solutions were stated:

  • reinstall Zwift app
  • try on a different device
  • turn off all Bluetooth devices that could cause interference

I tried everything several times but still no sensor data available. I even connected the Zwift hub to my Wahoo ELEMNT Roam with no problem but again no data (power, speed, cadence).

Does anyone have this issue and knows how to solve it?

Thank you!

Best regards
Leonard

sounds like a faulty unit, seems to be a common occurrence but try it with something like RGT and if thy doesn’t work sounds like the unit is faulty

I had exactly the same issue.Tried absolutely everything.Recieved a replacement and it fired up straight away.

My hub worked great for one ride, then 10 minutes into my next ride two days later the same thing happened. It connects to two different laptops and three different bike computers just fine, it just doesn’t transmit speed, cadence, or power data. I’ve opened a ticket with Zwift but I’m not feeling very confident :roll_eyes: