Zwift Hub Calibration wrench no show

Got my brand new Zwift hub today. Some minor issues but figured them out. Updated to the latest firmware and test rode in game on my Windows 11 PC. The problem is I cannot figure out how to calibrate the Zwift hub. Read / listened to everything I could find. I never see the “wrench” icon after pairing in game to the trainer. I have the luxury of connecting either Bluetooth or ANT+ but no matter what I use, no wrench. I finally rode in game for 11 minutes then went back to see if the wrench was now shown but was not. Finally disconnected and reconnected and still no wrench. What am I doing wrong?

They are self-calibrating :wink:

Well … they are eventually supposed to be. At least according to Zwift’s own videos and news releases. But the current “how to” say to calibrate it when you first get it, any time you move it, and once a month. So I’m going to assume you are jumping the gun a bit (yes, I noticed the wink but others may not).

No experience, I was just going by the sales pitch as being one of the differentiators to the Jetblack version. Fairly poor that you have to calibrate it at all tbh.

One thing I have noticed with the wrench on pairing screen is that it appears on my screen sometime after my Kickr has paired (maybe up to 15-30seconds?!?!) - so maybe it just needs some time tohandshake to recognise it - I’m clutching at straws though.

Yeah … well … I waited 11 minutes in case the Zwift comment of "… ride at least 10 minutes before calibration. " really means, “You won’t see the wrench for 10 minutes”.

Did you try the companion app? Isn’t there some functionality there?

I did. Initially you have to link it up with the companion app to update the firmware. After that I exited the companion app and loaded the game. Actually, if you don’t disconnect from the hub from the companion app, you cannot link up in the game. And likewise, you have to disconnect from the game to be able to link back up with the companion app. The latter is really obvious as the companion app tells you so. Not so much the other way. In any case I did got through a couple of those iterations but settled back on trying to get the “wrench” in game as all the videos and text I’ve read say so. Annoying the videos show you a presentation that clearly is not off a PC (interface entirely different) but in the end, pretty sure either it does not work (yet) or there is something I need to do that was not obvious in the docs available. Thanks for the response.

So we have to deal with hundreds or thousand uncalibrated smart trainers right now? Racing on Zwift must be real fun right now.

So I got an “official” response (see link). I had read this already. Maybe the only thing I did wrong is after riding 11 minutes I went back to the pairing screen to see if there was a “wrench”. I saw none so I unpaired and re-paired and still no wrench. The link tells you to end the ride then look again. Guess I will try again today. Funny thing is, the link also says that if the “wrench” does not show, contact your vendor. LOL. Ummm Zwift, that is you!! I got a feeling this is a canned response for any trainer. Ummm. Cannot post a link. So look under supportDOTzwiftDOTcom for “cycling”, “Advanced Features for Cycling”, “Perform a Calibration Spindown”.

The content of the official response email (no links) was:

  1. Open Zwift.
  2. Sign in to your Zwift account.
  3. Pair your devices and complete a quick ride—at least 10 minutes—to warm up your trainer.
  4. After ending your ride, return to the PAIRED DEVICES screen.

Then, after exiting, you should see the missing icon.

However, it is also worth performing a calibration, which can be performed as follows:

  1. Pair your devices and then select the wrench icon underneath POWER SOURCE .
  2. When the CALIBRATE SPINDOWN window opens, select NEXT .
  3. Follow the on-screen prompts to perform the calibration spindown.
  4. When complete, the CALIBRATE SPINDOWN window will display SUCCESS.
  5. Select OK , or wait for the window to automatically close.

Hello @T_Harrigan-SCG_BBC !

The spindown calibration wrench should appear when you’re fully paired (to Power, Cadence, and Controllable) over a Bluetooth connection. If you are only paired to one of these options, or paired via ANT+, the wrench may not appear on your device.

Feel free to DM me and we can troubleshoot more. I’m happy to work on this with you 1:1 in case this is a unique issue.

1 Like

Will do. This evening (eastern time) or sometime next week. Am a retired software firmware engineer so I am somewhat competent. Will reply again in email with phone number. You obviously have my email address. Will be away most the weekend on an end of season century event with a dozen cycling friends.

FWIW, anytime between 6 pm and 9 pm tonight. Probably best to wait until next week since I am away most the weekend on a bike trip. Mobile is XXX-XXX-XXXX. To coordinate next week should it be necessary, give me a ball park on when via email. Retired so have the time.

EDIT: Moderator - Removed personal information

@Gerrie_Delport_ODZ can you please remove the phone number above.

@T_Harrigan-SCG_BBC please don’t post your personal contact info on the forums, thanks!

2 Likes

Thanks. Yeah. Unintentional. Thought that was going direct to the support rep.

1 Like

So I did an initial test tonight (Thursday, Oct 6th @ approx 10:00 PM GMT). In short, it worked tonight. I admittedly was focusing more on ANT+ than Bluetooth initially since I was seeing some interference with Bluetooth (I have a few computers and devices). But I know I did do at least one Bluetooth only test (I R (was) a software firmware test engineer before retirement). I will do some more tests with other configurations but I figured you’d want this to know at least in this specific scenario I saw the wrench and successfully calibrated the hub. Test details follow.

OMEN HP 45L Intel Core i7-12700k 3.61 GHz
16 GB ram
Windows 11 Home
21H2
No pending Windows updates as of 10-06-2022
Norton 360 running in background.
NVIDIA GeForce RTX 3060 Ti
Logitech wireless keyboard and mouse via Logitech unifying receiver.
VIZIO SB2821 Bluetooth sound bar. Paired. Making sounds.

No heart rate strap to confuse things.
Zwift Trainer NOT manually paired to PC.
Pixel 6 powered off.
Test start: 10:02:00 PM GMT
No Zwift game request to update.
log in (10:02:28 PM GMT)
Force all connections to Bluetooth (10:03:38 PM GMT)
---- Forced “Power Source” to Bluetooth. (Zwift Hub 7D96) Immediately saw wrench.
Performed calibration (finished by 10:08:00 GMT) even though trainer was not warmed up properly
10:09:27 GMT - Entered game world. Things functioned.
10:11:00 GMT - left game world.
Returned to Paired device screen. Still see wrench (expected).
10:12:22 GMT - Exited game program.

So if I was not clear, it worked. Been a long day (riding, home chores) and I have weekend plans that start tomorrow (Friday) morning. But I will follow up on this next week. As an engineer I prefer to completely understand the problem and solutions. Personally, I want to see it’s an ANT+ plus “feature” and that adding my HR strap and Pixel 6 phone have no impact to the ability to calibrate as that was how I was testing initially.

Standard software testing principle: KISS (Keep It Simple Stupid) then complicate it.

Thanks.

@T_Harrigan-SCG_BBC glad that you found a solution.

The calibration wrench icon may not show because the Companion app needs to have your permission to Locations access in the OS. I wanted to link out to that solution here for those who google their way to this discussion.

I don’t see my reply to support here (yet - sent it a couple of hours ago) but in short, BOTH “Power Source” and “Controllable” MUST be a Bluetooth connection. When either of these are connected to ANT+, the wrench does not show. When I first got the trainer, I tried various combinations and I thought I tried everything being Bluetooth but if I did, then something else was different than it is now.

1 Like